Bug #69697 Manual has not enough details on how to use transportable tablespaces
Submitted: 9 Jul 2013 12:33 Modified: 19 Jul 2013 18:06
Reporter: Valeriy Kravchuk Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S2 (Serious)
Version:5.6 OS:Any
Assigned to: Bugs System CPU Architecture:Any
Tags: transportable tablespace
Triage: Needs Triage: D3 (Medium)

[9 Jul 2013 12:33] Valeriy Kravchuk
Description:
This manual page, http://dev.mysql.com/doc/refman/5.6/en/tablespace-copying.html, does NOT provide enough details on how to copy tablespace (.ibd file) to another server. Specifically, what should be done on target server to get data from existing .ibd file "transported" from other instance, step by step, and what messages user should expect in the error log and interactive session in the process.

How to repeat:
Try to find out how to copy single InnoDB table in its own tablespace from one server to the other based on information and links at http://dev.mysql.com/doc/refman/5.6/en/tablespace-copying.html.

Suggested fix:
Check http://mysqlblog.fivefarmers.com/2012/09/07/understanding-innodb-transportable-tablespaces... for the level of details needed. Now, when MySQL 5.6 is GA, I'd expect manual to have more details than some blog post created at RC stage.
[9 Jul 2013 14:56] Sveta Smirnova
Thank you for the report.

Verified as described.
[9 Jul 2013 17:11] Valeriy Kravchuk
It would be also useful to have all these messages in the error log explained:

...
2013-07-09 19:28:53 12759 [Note] /home/openxs/dbs/5.6/bin/mysqld: ready for connections.
Version: '5.6.12-debug'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Server (GPL)
2013-07-09 19:31:17 12759 [Note] InnoDB: Sync to disk of '"test"."b"' started.
2013-07-09 19:31:17 12759 [Note] InnoDB: Stopping purge
2013-07-09 19:31:17 12759 [Note] InnoDB: Writing table metadata to './test/b.cfg'
2013-07-09 19:31:17 12759 [Note] InnoDB: Table '"test"."b"' flushed to disk
2013-07-09 19:31:23 12759 [Note] InnoDB: Deleting the meta-data file './test/b.cfg'
2013-07-09 19:31:23 12759 [Note] InnoDB: Resuming purge
2013-07-09 19:32:09 12759 [Note] InnoDB: Sync to disk of '"test"."b"' started.
2013-07-09 19:32:09 12759 [Note] InnoDB: Stopping purge
2013-07-09 19:32:09 12759 [Note] InnoDB: Writing table metadata to './test/b.cfg'
2013-07-09 19:32:09 12759 [Note] InnoDB: Table '"test"."b"' flushed to disk
2013-07-09 19:32:11 12759 [Note] InnoDB: Deleting the meta-data file './test/b.cfg'
2013-07-09 19:32:11 12759 [Note] InnoDB: Resuming purge
2013-07-09 19:35:27 12759 [Note] InnoDB: Sync to disk of '"test"."b"' started.
2013-07-09 19:35:27 12759 [Note] InnoDB: Stopping purge
2013-07-09 19:35:27 12759 [Note] InnoDB: Writing table metadata to './test/b.cfg'
2013-07-09 19:35:27 12759 [Note] InnoDB: Table '"test"."b"' flushed to disk
2013-07-09 19:35:30 12759 [Note] InnoDB: Deleting the meta-data file './test/b.cfg'
2013-07-09 19:35:30 12759 [Note] InnoDB: Resuming purge
2013-07-09 19:35:40 12759 [Note] InnoDB: Sync to disk of '"test"."b"' started.
2013-07-09 19:35:40 12759 [Note] InnoDB: Stopping purge
2013-07-09 19:35:40 12759 [Note] InnoDB: Writing table metadata to './test/b.cfg'
2013-07-09 19:35:40 12759 [Note] InnoDB: Table '"test"."b"' flushed to disk
2013-07-09 19:35:43 12759 [Note] InnoDB: Deleting the meta-data file './test/b.cfg'
2013-07-09 19:35:43 12759 [Note] InnoDB: Resuming purge
2013-07-09 19:38:09 12759 [Note] InnoDB: Sync to disk of '"test"."b"' started.
2013-07-09 19:38:09 12759 [Note] InnoDB: Stopping purge
2013-07-09 19:38:09 12759 [Note] InnoDB: Writing table metadata to './test/b.cfg'
2013-07-09 19:38:09 12759 [Note] InnoDB: Table '"test"."b"' flushed to disk
2013-07-09 19:39:14 12759 [Note] InnoDB: Deleting the meta-data file './test/b.cfg'
2013-07-09 19:39:14 12759 [Note] InnoDB: Resuming purge
2013-07-09 19:39:26 12759 [Note] InnoDB: Sync to disk of '"test"."b"' started.
2013-07-09 19:39:26 12759 [Note] InnoDB: Stopping purge
2013-07-09 19:39:26 12759 [Note] InnoDB: Writing table metadata to './test/b.cfg'
2013-07-09 19:39:26 12759 [Note] InnoDB: Table '"test"."b"' flushed to disk
2013-07-09 19:41:02 12759 [Note] InnoDB: Deleting the meta-data file './test/b.cfg'
2013-07-09 19:41:02 12759 [Note] InnoDB: Resuming purge
2013-07-09 19:45:26 12759 [Note] InnoDB: Importing tablespace for table 'test/b' that was exported from host 'debian7'
2013-07-09 19:45:26 12759 [Note] InnoDB: Phase I - Update all pages
2013-07-09 19:45:26 12759 [Note] InnoDB: Sync to disk
2013-07-09 19:45:26 12759 [Note] InnoDB: Sync to disk - done!
2013-07-09 19:45:26 12759 [Note] InnoDB: Phase III - Flush changes to disk
2013-07-09 19:45:26 12759 [Note] InnoDB: Phase IV - Flush complete
2013-07-09 19:47:51 12759 [Note] InnoDB: Importing tablespace for table 'test/b' that was exported from host 'debian7'
2013-07-09 19:47:51 12759 [Note] InnoDB: Phase I - Update all pages
2013-07-09 19:47:51 12759 [Note] InnoDB: Sync to disk
2013-07-09 19:47:51 12759 [Note] InnoDB: Sync to disk - done!
2013-07-09 19:47:51 12759 [Note] InnoDB: Phase III - Flush changes to disk
2013-07-09 19:47:51 12759 [Note] InnoDB: Phase IV - Flush complete
...

At least messages that mean failure in the process (if any).
[10 Jul 2013 19:51] Shannon Wade
This is a duplicate of 68171 (recently closed jul 8th)
[10 Jul 2013 19:53] Shannon Wade
Though missed 2nd note about explaination of syncing messages. This would be very helpful as well.
[19 Jul 2013 18:06] Bugs System
Additional information about the transportable tablespace copying procedure has been added including a limitations section and an internals/error log messaging section. 

The revised content will appear soon, in the next published documentation build.  

http://dev.mysql.com/doc/refman/5.6/en/tablespace-copying.html
http://dev.mysql.com/doc/refman/5.7/en/tablespace-copying.html

Thank you for the bug report.