Bug #69640 Query editor tab lacks a horizontal scrollbar when long query is pasted
Submitted: 1 Jul 2013 18:38 Modified: 3 Jul 2013 15:57
Reporter: Ben J Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.0.2.10924 OS:Microsoft Windows (7 SP1)
Assigned to: CPU Architecture:Any

[1 Jul 2013 18:38] Ben J
Description:
Firstly, this bug may be the same as #66747, but this still happens in 6.0.2.10924, which is a different major version than that entered in the aforementioned ticket.

Whenever I paste-in a query that is wider than the query editor window, there is no horizontal scrollbar in the query editor.

I have to position the cursor on the longest line, manually, and then hit the "End" key on my keyboard (or arrow-over with the right arrow key) for the scrollbar to appear.

Once the horizontal scrollbar is added, if I then delete the entire query, the scrollbar does not disappear; it remains the same length.

So, there are, in effect, two separate problems here, but perhaps the root-cause is the same.

It is safe to say that the scrollbar updating mechanism is disconnected from the editor's actual content in some fundamental way.

How to repeat:
Copy a "long query" (its width must be longer than what can fit into the query editor window without horizontal scrolling) to the clipboard, open a new SQL editor tab in Workbench, and paste-in the query.

Suggested fix:
Call whatever method is used to update the scrollbar whenever the editor windows' content changes.
[3 Jul 2013 15:57] Mike Lischke
Duplicate of Bug #66747