Bug #69534 GO and EGO commands not working in CLI
Submitted: 20 Jun 2013 22:01 Modified: 21 Jun 2013 12:40
Reporter: Domas Mituzas Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:all OS:Any
Assigned to: Georgi Kodinov CPU Architecture:Any

[20 Jun 2013 22:01] Domas Mituzas
Description:
In CLI 'go' and 'ego' commands don't work:

mysql> select 1
    -> go
    -> 

mysql> select 1
    -> ego
    -> 

By themselves they complain about query not being there:

mysql> go
ERROR: 
No query specified

mysql> ego
ERROR: 
No query specified

yet these commands sure exist, from help output:
...
ego       (\G) Send command to mysql server, display result vertically.
...
go        (\g) Send command to mysql server.
...

How to repeat:
mysql CLI

Suggested fix:
dunno, something is broken here!
[21 Jun 2013 6:37] Umesh Shastry
Hello Domas,

Thank you for the report.
Verified as described.

// from latest GA

mysql> select 1
    -> go
    -> 

mysql> select 1
    -> ego
    -> 
    
But the synonym's just works fine..

mysql> select 1\g
+---+
| 1 |
+---+
| 1 |
+---+
1 row in set (0.00 sec)

mysql> select 1\G
*************************** 1. row ***************************
1: 1
1 row in set (0.00 sec)

Thanks,
Umesh
[21 Jun 2013 12:40] Georgi Kodinov
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Domas,

The text that the help command prints starts like this : 
"
List of all MySQL commands:
Note that all text commands must be first on line and end with ';'
"

I read this to mean that you'll have to send "go" and "ego" as a first and only command on the line.
This obviously doesn't make a lot of sense, as there's no command text to send so you get an error instead :)

mysql> go
ERROR:
No query specified

mysql> ego
ERROR:
No query specified

mysql>

Note that other mysql commands don't work too if they're not first on the line : 

mysql> select help
    -> ;
--------------
select help
--------------

ERROR 1054 (42S22): Unknown column 'help' in 'field list'
mysql> help

For information about MySQL products and services, visit:
   http://www.mysql.com/
[21 Jun 2013 13:10] Georgi Kodinov
Rereading my comment I've just noted that it said "line" in the help message. This was probably written before the multi-line support mode :)
It must have said "multi-line command buffer" or something similar. Feel free to reopen if you feel that this should be fixed.
[21 Jun 2013 17:30] Mike Griffin
The \h documentation has long been confusing / misleading:

List of all MySQL commands:
Note that all text commands must be first on line and end with ';'
?         (\?) Synonym for `help'.

mysql> use mysql
Database changed

mysql> delimiter ^^;
mysql>
mysql> select 1 from dual^^
    ->
[21 Jun 2013 19:57] Shane Bester
Domas, start client with --named-commands :)

mysql> select 'hi'
    -> go
+----+
| hi |
+----+
| hi |
+----+
1 row in set (0.00 sec)