Bug #69512 Wrong license in man pages in Community Server
Submitted: 19 Jun 2013 7:28 Modified: 6 Aug 2013 17:02
Reporter: Norvald Ryeng Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.1.70, 5.5.32, 5.6.12, 5.7.1-m11 OS:Any
Assigned to: Balasubramanian Kandasamy CPU Architecture:Any

[19 Jun 2013 7:28] Norvald Ryeng
Description:
The man pages of Community Server should be GPL, but since 5.5.31, packages have contained man pages with a different license. 5.5.30 man pages are correctly licensed.

The bug exists in the latest release of 5.1, 5.5, 5.6 and 5.7. I haven't checked older versions of 5.1, 5.6 or 5.7.

How to repeat:
Read the man pages.

Suggested fix:
Change back to the correct license.
[19 Jun 2013 7:52] Yngve Svendsen
Thank you for the report. This is indeed a bug, where the build system erroneously and silently started pulling in man pages with the wrong set of copyright headers.
[19 Jun 2013 8:23] Balasubramanian Kandasamy
Working on the fix.
[19 Jun 2013 8:47] Yngve Svendsen
Once the fixes have been made to the build system, we will rebuild the latest 5.1, 5.5, 5.6 releases plus the latest 5.7 milestone and make those available publicly asap.
[19 Jun 2013 18:00] Yngve Svendsen
5.5 rebuilds started. Other versions will follow as soon as these have been confirmed to contain the correctly licensed man files.
[19 Jun 2013 18:28] Balasubramanian Kandasamy
Fix tested on 5.5.32 release branch. GPL packages has got the correct man pages now.

Re-build in progress for 5.6.12 and 5.7.1 release branches.
[20 Jun 2013 10:23] Yngve Svendsen
5.7.1 packages handed over to QA. More to come.
[20 Jun 2013 11:37] Balasubramanian Kandasamy
5.5.32 packages handed over to QA.
[22 Jun 2013 17:04] Balasubramanian Kandasamy
We have got QA sign-off. We are in process of publishing the packages.
[24 Jun 2013 7:44] Balasubramanian Kandasamy
5.5.32, 5.6.12 and 5.7.1 rpms with fixes published to http://dev.mysql.com/ now.

We will publish 5.1.70 to the http://dev.mysql.com/ soon.

Thanks,
[24 Jun 2013 10:05] Ulrich Müller
For the mysql-5.5.32.tar.gz tarball, the GPG signature at <http://dev.mysql.com/downloads/gpg.php?file=mysql-5.5.32.tar.gz> seems to be bad.

Also, is there any official statement what is the license of man pages in 5.1.69 and 5.5.31? Are distros allowed to redistribute these versions?
[24 Jun 2013 14:00] Bjørn Munch
GPG signatures should be fixed now. What happened was that we did upload all the new signatures but since the old ones already existed in the download system, they had to be manually updated.

Source and all binary packages for 5.5.32, 5.6.12 and 5.7.1 were rebuilt and re-uploaded, except Windows packages which do not contain man pages.
[26 Jun 2013 13:04] Hartmut Holzgraefe
please don't tell me you've re-released files with the same version number / file name but with different contents? ....
[26 Jun 2013 13:04] Hartmut Holzgraefe
You indeed have ... $trust--
[26 Jun 2013 15:38] Simon Mudd
You now have this new "affects me" button which is good. Please can you share at least how many others are subscribed (email updates) [you may not want to do this] or say "affects me", as otherwise this useful addition is not helpful to the public at large. Releasing different source with the same files is indeed confusing especially for packagers who use this source to build binaries.
[26 Jun 2013 16:43] Hartmut Holzgraefe
@Simon: see http://bugs.mysql.com/bug.php?id=69569
[1 Jul 2013 6:34] Balasubramanian Kandasamy
5.1.70 builds QA testing is in progress.
[1 Jul 2013 8:05] Hartmut Holzgraefe
"[1 Jul] 5.1.70 builds QA testing is in progress" ???

Please don't say that you are about to create yet a third set of 5.1.70 packages under the same name / version number?

(see also http://bugs.mysql.com/bug.php?id=69598 )
[3 Jul 2013 12:08] Yngve Svendsen
@Hartmut, @Simon,

With hindsight, we should not have gone for a silent replace. We should ideally have bumped the version number or at least the release number. As a partial fix, to signify actual changed content and preserve upgradability, we will publish new RPMs with release number 2 (e.g. 5.5.32-2). And we will avoid silent replaces in the future by being stricter about bumping version numbers on source code changes and release numbers on pure packaging changes.
[3 Jul 2013 13:27] Yngve Svendsen
@Ulrich,

to be absolutely sure wrt. the legal side of this, we recommend that distros pick up the latest respins of the 5.1.70 and 5.5.32 packages.
[10 Jul 2013 6:21] Balasubramanian Kandasamy
5.5.32, 5.6.12 rpms with updated rpm version (-2) published to http://dev.mysql.com/ now.
[11 Jul 2013 8:09] Balasubramanian Kandasamy
5.7.1 m11 rpms with updated version (-4) published to dev.mysql.com
[1 Aug 2013 10:37] Balasubramanian Kandasamy
5.1.70 rebuilt rpms(-2) published to http://dev.mysql.com/.

Apologizes !!! We had to fix intermittent build environment issue for 5.1.70 that delayed the release. 

Closing the ticket as fix has been released across all release branches.

Please re-open the ticket, if you still see any issues.

Thanks,
[6 Aug 2013 17:02] Paul Dubois
Issue closed. No changelog entry because the issue applies only to earlier builds that were replaced by fixed builds.
[6 Aug 2013 17:18] Hartmut Holzgraefe
IMHO this would have required a big warning in changelogs that two different versions of the packages exist, including the source tarballs, with the same file names but different contents ...