Bug #6950 mysql-nt.exe error when click on sql or database on mysql control center
Submitted: 2 Dec 2004 15:46 Modified: 11 Feb 2005 21:35
Reporter: Darien Tran Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.02 essential-win OS:Microsoft Windows (windows XP)
Assigned to: Sergei Glukhov CPU Architecture:Any

[2 Dec 2004 15:46] Darien Tran
Description:
I tested on the new version that you have.. When I use Mysql control center with it. It has trouble when you click on the database or run sql. It will generate a windows error, mysql-nt error, and the mysql service will automatically stop. The 4.1 version is fine.

How to repeat:
a
[2 Dec 2004 16:14] Miguel Solorzano
I tested with non-installer release package and it is a server crash.
I will back with the call stack.

Thank you for the bug report.
[2 Dec 2004 16:49] Miguel Solorzano
Below call stack from server build with source release package:

>	mysqld.exe!my_utf8_uni(charset_info_st * cs=0x0082c628, unsigned long * pwc=0x03e6e764, const unsigned char * s=0x00951000, const unsigned char * e=0x009585fb)  Line 1768 + 0x3	C
 	mysqld.exe!my_ismbchar_utf8(charset_info_st * cs=0x0082c628, const char * b=0x00951000, const char * e=0x009585fb)  Line 2257 + 0x15	C
 	mysqld.exe!my_numchars_mb(charset_info_st * cs=0x0082c628, const char * pos=0x00951000, const char * end=0x009585fb)  Line 245 + 0x15	C
 	mysqld.exe!String::numchars()  Line 547 + 0x25	C++
 	mysqld.exe!Item_string::Item_string(const char * str=0x009485fc, unsigned int length=65535, charset_info_st * cs=0x0082c628, Derivation dv=DERIVATION_COERCIBLE)  Line 858 + 0xb	C++
 	mysqld.exe!create_schema_table(THD * thd=0x00ebe0e0, st_table_list * table_list=0x00eb97f0)  Line 2945 + 0x2d	C++
 	mysqld.exe!mysql_schema_table(THD * thd=0x00ebe0e0, st_lex * lex=0x00ebe128, st_table_list * table_list=0x00eb97f0)  Line 3137 + 0x11	C++
 	mysqld.exe!open_tables(THD * thd=0x00ebe0e0, st_table_list * start=0x00eb97f0, unsigned int * counter=0x03e6e8cc)  Line 1664 + 0x17	C++
 	mysqld.exe!open_and_lock_tables(THD * thd=0x00ebe0e0, st_table_list * tables=0x00eb97f0)  Line 1878 + 0x11	C++
 	mysqld.exe!mysql_execute_command(THD * thd=0x00ebe0e0)  Line 2164 + 0xd	C++
 	mysqld.exe!mysql_parse(THD * thd=0x00ebe0e0, char * inBuf=0x00eb90a8, unsigned int length=40)  Line 4662 + 0x9	C++
 	mysqld.exe!dispatch_command(enum_server_command command=COM_QUERY, THD * thd=0x00ebe0e0, char * packet=0x00eb5045, unsigned int packet_length=41)  Line 1507 + 0x1d	C++
 	mysqld.exe!do_command(THD * thd=0x00ebe0e0)  Line 1315 + 0x31	C++
 	mysqld.exe!handle_one_connection(void * arg=0x00ebe0e0)  Line 1047 + 0x9	C++
 	mysqld.exe!pthread_start(void * param=0x02f71e90)  Line 63 + 0x7	C
 	mysqld.exe!_threadstart(void * ptd=0x00eb4198)  Line 173 + 0xd	C
 	kernel32.dll!7c80b50b() 	
 	kernel32.dll!7c8399f3()
[3 Dec 2004 8:48] Sergei Glukhov
Suggested fix on dev-bugs(subj: Suggested fix for bug#6955, 6950)
[6 Dec 2004 6:46] Sergei Glukhov
Fixed in 5.0 source tree
[10 Jan 2005 14:08] edmund
so how can i solve this bug. can you tell me more detail? i don't understand!
[10 Jan 2005 18:07] Augusto Murri
Hi,
i've a bug in mysql5.02 alpha-net relase when i use 'SHOW FULL FIELDS FROM table1'.. my mysql-nt crash.

This is the report:
szAppName : mysqld-nt.exe     szAppVer : 0.0.0.0     szModName : mysqld-nt.exe
szModVer : 0.0.0.0     offset : 001346c4  

someone can help me to resolve that problem?

bye
[11 Jan 2005 2:17] edmund
Please help us to solve this problem! Thank you for your information. I need it for testing my program.
[14 Jan 2005 11:56] Natale Babbo
i have the same problem with mysql 5.0.2 on windows 2000 when i do a "SHOW FIELDS" command.
i don't undestand if the problem is solved or not.
please let me know.

thanks.
[18 Jan 2005 3:44] edmund
Dear Sir

I had found the duplicate report bug, I see that most of the people still want to know the solution how mysql-nt.exe error. Please tell us, how to solve it? It seems urgent for solving it!

Regards
Edmund
[21 Jan 2005 9:37] Peter Solti
Hi,

I encounter the same problem.
I did some workaround but no success unfortunately.

Still like others really waiting for the solution !

Cheers
[21 Jan 2005 12:15] Sergei Glukhov
fixed in 5.0.3
[21 Jan 2005 15:34] Sorin Ploscaru
and..... where is it 5.0.3? no cvs....pls, i want binary archive...
[23 Jan 2005 17:02] [ name withheld ]
Hi, 
I've the same problem.... mysql-nt.exe....error when open a catalog.... 
where is link to download the new fix 5.0.3???

Regards
Ago
[27 Jan 2005 21:57] Peter Rotscheid
I've the same problem
mysql-nt.exe....error when open a catalog.... or ref to col option
where is link to download the new fix 5.0.3???

Regards
Peter
[3 Feb 2005 8:38] Peter Solti
Hi Guys,

As far as I know, this 5.0.3 version is not downloadable for today. It can be built by yourselves, from code.
Go to the relevant section if you interested a min. 1 full day process :)
(on linux it is much easier, because for Win you need C++ installed...)

I hope, it will be distributed soon for us as a downloadable version. But you never know...

Best regards,

P├ęter Solti
[5 Feb 2005 14:11] Manuel Wenger
Is there absolutely no way to get a 5.0.3 binary for Windows? I need to do some testing with triggers. I understand that 5.0 isn't supposed to be used in productive environments yet, but I'm stuck at this point. I can't go and purchase MS Visual Studio just to compile MySQL. Anyone please? :-)
[15 Feb 2005 20:54] Tim Champion
FYI, I got an Email response from Matt Wagner on the ETA for a new Win32 binary (5.0.3). Here is his repsonse (on 2/15/2005):

>We've been spending a lot of energy on Certified Binaries for our new "MySQL
>Network" that was launched today.
>
>Now we will focus on releasing 5.0.3. I would guess that it will be done
>within the next 2 weeks.
>
>
>   Matt
[11 Mar 2005 14:25] Keith Law
I also encountered this problem. But may I know anyone who can try successful in window2000? Thanks.

I am now reversing back to 4.1 and I am expecting the latest one which can use the stored procedure... :|
[20 Jul 2007 13:47] Sherry Gibbons
I am trying to load SAM on my computer and when it gets to a certain point I am getting the "mysql-nt.exe" error message, and my SAM software cannot load.  What is the problem with this?  Should I install the earlier version of MySQL?

Sherry