Bug #69256 Workbench SQL Error 1064 on Save Changes on Schema Privilages
Submitted: 16 May 2013 8:44 Modified: 9 Jan 2015 9:48
Reporter: Dave Walker Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.47 CE OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: 1064, Schema Privileges, workbench

[16 May 2013 8:44] Dave Walker
Description:
Workbench produces a SQL Error 1064 on Saving Changes of Schema Privilages for schemas containing an underscore (_).

The query workbench generates incorrectly escapes the underscore.

This bug was not present in Workbench version 5.2.44 CE.

How to repeat:
- Create a schema containing an underscore.
- Attempt to assign schema privileges to the schema

Suggested fix:
Do not escape underscores in this generated query.
[16 May 2013 8:57] Umesh Shastry
Thank you for the bug report, duplicate of http://bugs.mysql.com/bug.php?id=68175