Bug #69049 Opening blob field data in Editor takes 10-40 sec
Submitted: 24 Apr 2013 8:57 Modified: 21 Aug 2014 1:26
Reporter: Konstantin Hatuntcev Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.47 CE OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: BLOB ValueEditor

[24 Apr 2013 8:57] Konstantin Hatuntcev
Description:
Opening blob field data (containing 65k jpg image) in Value Editor takes 10-40 sec (depends of previous selected tab in window "Edit Data for") to complete while GUI completely hanging.
There was no such issue in previous version.

How to repeat:
Create table with blob column, add some jpeg picture to it and try to observe it using Value Editor.
[24 Apr 2013 9:05] Konstantin Hatuntcev
screenshot of hanging

Attachment: 2013-04-24_130435.png (image/x-png, text), 101.34 KiB.

[24 Apr 2013 11:52] MySQL Verification Team
Verified on machine with below System Info:

MySQL Workbench CE for Windows version 5.2.47  revision 10398

Configuration Directory: C:\Users\miguel\AppData\Roaming\MySQL\Workbench

Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.47

Cairo Version: 1.8.8

OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit

CPU: 8x Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz, 7.9 GiB RAM

Active video adapter NVIDIA GeForce GT 540M

Installed video RAM: 2047 MB

Current video mode: 1366 x 768 x 4294967296 colors

Used bit depth: 32

Driver version: 9.18.13.697

Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Current user language: Portuguese (Brazil)
[21 Aug 2014 1:26] Philip Olson
Fixed as of the MySQL Workbench 6.2.0 release, and here's the changelog entry:

Opening BLOB field data (such as an average sized image) in the Value
Editor could take 10-40 seconds to load.

Thank you for the bug report.