Bug #69012 Depreceate mysqlaccess
Submitted: 19 Apr 2013 18:25 Modified: 17 Feb 2014 3:32
Reporter: Todd Farmer (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.6.11 OS:Any
Assigned to:

[19 Apr 2013 18:25] Todd Farmer
Description:
The mysqlaccess Perl script is exceedingly old (seemingly untouched since 3.21 days back in 2000), works only on *nix systems, and has no understanding of recent developments in MySQL, such as new privileges, external authentication plugins, proxy users, "new" schema objects such as VIEWs and STORED ROUTINEs.  It's hard to imagine it has any remaining value, and surely should not be shipped with current releases of MySQL.

How to repeat:
N/A

Suggested fix:
Deprecate and remove mysqlaccess from MySQL server builds going forward.  If community expresses ongoing need, create a "deprecated clients/scripts" package for easy download independent of MySQL server.
[17 Feb 2014 3:32] Paul Dubois
Noted in 5.6.17, 5.7.4 changelogs.

The msql2mysql, mysql_convert_table_format, mysql_find_rows,
mysql_fix_extensions, mysql_setpermission, and mysqlaccess utilities
are deprecated in MySQL 5.6.17 and removed in MySQL 5.7.4.