Bug #69010 Innodb transfer to another system fails due to innodb full text - assertion fail
Submitted: 19 Apr 2013 14:20 Modified: 25 Apr 2013 10:33
Reporter: Charles Peterson Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: FULLTEXT search Severity:S1 (Critical)
Version:5.6.10 OS:Linux
Assigned to: CPU Architecture:Any
Tags: assertion failure, fulltext, innodb, parent table, pars0pars, warning

[19 Apr 2013 14:20] Charles Peterson
Description:
After shutdown and transfer of mysql to another machine I get errors about the fulltext aux. table not finding their parents....

2013-04-19 02:58:57 1684 [Warning] InnoDB: Parent table of FTS auxiliary table test/FTS_0000000000001019_STOPWORDS not found.

Then there is an Assertion Failure when MySQL actually starts.

2013-04-19 03:00:38 7f63e75f9700  InnoDB: Assertion failure in thread 140067060291328 in file pars0pars.cc line 865
InnoDB: Failing assertion: sym_node->table != NULL
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
08:00:38 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

I have tried this multiple times with the same results.

How to repeat:
create db and innodb table with full text index on it.
Fill with some data.
shut down mysql
transfer to another instance on another server (entire mysql directory)
update permissions for the files if needed (mysql:mysql)
start mysql on new server

I will attach my err log asap.

Suggested fix:
Determine how linking is done for fulltext index aux. tables and adjust to be transferable?

Thank you for you time!!
[19 Apr 2013 14:21] Charles Peterson
Error Log

Attachment: mysql1.dev.com.err (application/octet-stream, text), 17.68 KiB.

[25 Apr 2013 10:33] Umesh Shastry
Hello Charles,

I can not repeat described behavior on latest GA 5.6.11
Could you please provide repeatable testcase(table structure, required data)?

Would it be possible for you to check if it's repeatable on the latest GA 5.6.11?
[25 Apr 2013 10:36] Umesh Shastry
steps followed during verification..

Attachment: 69010.txt (text/plain), 9.24 KiB.