Bug #68940 odbc driver '-' sign in hostname
Submitted: 12 Apr 2013 9:03 Modified: 1 Jul 2013 6:53
Reporter: Comune di Firenze Risorse Tecnologiche Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51.30 OS:Microsoft Windows
Assigned to: Bogdan Degtyariov CPU Architecture:Any
Tags: Connection, hostname, ODBC

[12 Apr 2013 9:03] Comune di Firenze Risorse Tecnologiche
Description:
I try to create adn odbc datasource using a hostname (a real name, "A" record in dns) or an alias containing a '-' minus sign.
Clicking on 'Test' we receive the message:
Unknown MySQL Server host '{db-mysqltest}' (0) .

The error remains even if I use a FQDN in the hostname.

When using a name (even a DNS alias) without the '-' minus sign or the ip in numeric format the connection is made.

From the command prompt all names are regularly resolved by the ping command.

All this happens in the usual windows ODBC manager.

We must use 3.51 version because more recent ones work bad with Delphi 5.
We did not have the problem with 3.21.27 (not more available for download).

Thanks in advance,
Comune di Firenze (Municipality of Florence).

How to repeat:
Create an ODBC data source with a hostname containing '-' minus sign.

Suggested fix:
Correctly use the character or find a way to escape it.
[15 Apr 2013 10:14] Bogdan Degtyariov
Hello,

Unfortunately, MySQL ODBC Driver version 3.51 has been discontinued.
This means it will not receive any new patches/fixes and no new releases are planned for it too.

However, you might try the version 5.2-ANSI, which has the extended compatibility with 3.51.

I checked the steps you provided against the version 5.2.4 and it worked well.
Can you please do the same and let me know whether it resolved your problem.
[15 Apr 2013 10:16] Bogdan Degtyariov
Changing S1 to S2 as not corresponding to the description of S1:

S1 (Critical): Represents a complete loss of service, a significant functionality is missing, a system that hangs indefinitely; and there is no available workaround.
[16 May 2013 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[31 May 2013 8:17] Bogdan Degtyariov
Please note that this bug report is waiting on your reply. It will be automatically closed if you do not provide us any feedback.
[1 Jul 2013 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[1 Jul 2013 6:53] Bogdan Degtyariov
No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you.