Bug #689 lost connection to mysql server while executing query
Submitted: 19 Jun 2003 22:37 Modified: 30 May 2013 8:07
Reporter: thiruvarul selvan Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:version 2.2 OS:Microsoft Windows (windows)
Assigned to: CPU Architecture:Any

[19 Jun 2003 22:37] thiruvarul selvan
Description:
19.	We frequently get a “lost connection to server” error for all pages , that’s definitely a big bug
An eg:

ADODB.Recordset.1 error '80004005' 
SQLState: S1000
Native Error Code: 2013
[TCX][MyODBC]Lost connection to MySQL server during query
/ViewBidResponse.asp, line 236 

i used this connection string.

strConnectionString="Driver={MySQL ODBC 3.51 Driver}; Server=localhost; Database=master; UID=root; PWD=" 

the above error occurs only when executing query.

pls help me to comeout from this problem.

How to repeat:
s

Suggested fix:
d
[19 Jun 2003 23:24] Venu Anuganti
Hi !!

Can you be more specific with the bug report ? Like when its occuring and what is your Connector/ODBC version and what is your MySQL server version and OS its running.

Also from your report, the error is from MyODBC 2.50, where in your connection string belongs to Connector/ODBC 3.51. Is it something that I missed or ..? 

And, thanks for contacting MySQL.
Venu
[2 Jul 2003 21:17] thiruvarul selvan
Hi,

I am surely know that this error not becoz of the connection string.

I am getting error while executing query.

I am getting error 

>ADODB.Recordset.1 error '80004005' 

>SQLState: S1000

>Native Error Code: 2013

>[TCX][MyODBC]Lost connection to MySQL server during query

in the database the value of the variables
connection_timeout is set to "5"
wait_timeout is set to "600"

may the error cause due to these values?

if so how do i change these values?

in mysql manual , i have seen that it should be updated in mysqld file

but i don't know how i execute mysqld file to change these values.

pls Help me to come out from this problem.

Thanking You!

Regards,
-Thiru
[15 Jul 2003 12:31] Venu Anuganti
Hi !! 

The reason why I asked for connection string is that, you are using Connector/ODBC 3.51 connection string, but the error that you are getting is from Connector/ODBC 2.50 old driver. You can distinguish both the drivers from its error prefix as they have this error prefixes: 

Connector/ODBC 2.50: [Tcx][MySQL]
Connector/ODBC 3.51: [MySQL][ODBC 3.51 Driver][mysqld-$version]
Connector/ODBC 3.52: [MySQL][ODBC 3.52 Driver][mysqld-$version]

So, just I wanted to make sure that, you reinstall the 3.51 driver from its installer.

Coming to your Lost connection issue, there are mainly 2 reasons for this error.

1. You might be using MySQL server installed in Redhat Linux from its own distribution and not directly from www.mysql.com. If this is the case, can you please reinstall MySQL server downloading from:
 http://www.mysql.com 
or by applying the Redhat errata from: http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75128

2. Your packet size is too big to send in a single transmission, and try to increase it to fix your needs.

If none of them are in your case, it will be good if you can attach a simple reproduciable test case.

Thanks and sorry for the delay in answering this bug report.
Venu
[30 May 2013 8:07] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.