Bug #6886 MySQL parser fails on function names not followed inmediately by a parentesis
Submitted: 29 Nov 2004 22:59 Modified: 29 Nov 2004 23:19
Reporter: Mauricio Ramirez Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: User-defined functions ( UDF ) Severity:S1 (Critical)
Version:All of them! OS:All of them
Assigned to:

[29 Nov 2004 22:59] Mauricio Ramirez
Description:
Hi!

I typed this statement as:

select UNIX_TIMESTAMP (NOW());

and it fails because there is a blank space after the UNIX_TIMESTAMP function name!

Please correct it!

Mauricio Ramirez

How to repeat:
select UNIX_TIMESTAMP (NOW());

Suggested fix:
Don´t know!
[29 Nov 2004 23:17] Paul Dubois
See: http://dev.mysql.com/doc/mysql/en/Functions.html
[29 Nov 2004 23:19] Hakan Küçükyılmaz
Hi,

this is not a bug. You can use IGNORE_SPACE to avoid this behaviour:
http://dev.mysql.com/doc/mysql/en/Server_SQL_mode.html

Regards, Hakan