Bug #68813 .NET Connector Memory Leak Calling Routines Repeatedly (Stored Procedures)
Submitted: 29 Mar 2013 15:09 Modified: 3 Apr 2013 17:20
Reporter: Michael Milliron Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / NET Severity:S5 (Performance)
Version:6.5.5.0 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: memory leak, routines, stored procedures

[29 Mar 2013 15:09] Michael Milliron
Description:
I have a project that reads a rather large XML file and does multiple inserts into various tables as it iterates thru the file.  I initially wrote inline SQL and had no problem processing thru the entire file using the .NET Connector.  I wrote Routines for all my inserts and converted my code to use the routines instead.  I know that with MySQL Routines, a performance increase is not seen unless you keep a persistent connection because they are saved in memory for the current connection, according to your documentation, so I kept a persistent connection as I iterated thru the file and I can get about a quarter way thru the file (5K parent elements) when my entire system freezes.  I have done multiple passes using inline code versus Routines and every time the inline code can complete without issue, using the Routines causes my system to eventually hang and freeze completely to where I need to reboot.  I'm not sure if this is an issue with the .NET Connector or ??.  MySQL cluster 5.5 

How to repeat:
I've switched my code back and forth - using a persistent connection that uses routines or inline code and I get the same result every time.
[29 Mar 2013 17:59] Michael Milliron
Please close - looks like the issue was my Intel on board network adapter - used a different nic and it works as expected.
[3 Apr 2013 17:20] Fernando Gonzalez.Sanchez
Thanks for taking your time to report it.

NOTE: Not a bug as per user report.