Bug #68675 fix broken build with solaris/gcc 32bit mode
Submitted: 14 Mar 2013 15:23 Modified: 15 Mar 2013 19:00
Reporter: Tor Didriksen Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.6 OS:Solaris
Assigned to: Tor Didriksen CPU Architecture:Any

[14 Mar 2013 15:23] Tor Didriksen
Description:
Fix misc warnings for gcc/solaris.

How to repeat:
Build with gcc on solaris.

Suggested fix:
do this before including any system headers:

// First include (the generated) my_config.h, to get correct platform defines.
#include "my_config.h"

the problem is that the FILE_OFFSET_BITS gets redefined

Actually: we get warnings with sun-studio as well,
but the build does not break.
The results are undefined though: several data structures have
different size in different compilation units.
[15 Mar 2013 19:00] Paul Dubois
Noted in 5.7.2 changelog.

Compilation on Solaris using gcc produced incorrect builds for 32-bit
systems.