Bug #68592 'only your bugs' is ignored in search
Submitted: 7 Mar 2013 9:05 Modified: 1 Aug 2013 16:47
Reporter: Peter Laursen (Basic Quality Contributor) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Websites: bugs.mysql.com Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D4 (Minor)

[7 Mar 2013 9:05] Peter Laursen
Description:
With specific settings it seems that the setting to find 'only your bugs' is ignored in search.

I enter 'system' as search string, check 'only your bugs'. Everything else is default. The URL generated is 

http://bugs.mysql.com/search.php?search_for=system&status=Active&severity=&limit=10&order_...

.. what returns 314 bugs of which only are few are mine.

I think it used to work not so long time ago.

How to repeat:
see above

Suggested fix:
Respect filters.
[7 Mar 2013 9:06] Peter Laursen
The filter dialog

Attachment: search.png (image/png, text), 16.59 KiB.

[7 Mar 2013 9:09] Peter Laursen
Seems that the search token 'system' is a problem.  With 'file' I get only my own bugs returned.
[11 Mar 2013 16:24] Miguel Solorzano
Thank you for the bug report.
[31 Jul 2013 23:01] Omer Barnir
Hi Peter,

We are unable to reproduce the problem - that is, when running the search 'as you' and limiting the search to include 'system' we get correct results (11 bugs all reported by you).

Can you provide a screenshot of the results that include 'wrong' bugs and the url so we can debug further?

Thanks
==Omer
[1 Aug 2013 7:35] Peter Laursen
I cannot either now.

Probably I was not logged in and confusion could have happened because of login system being changed when using 'the unified Oracle login' for this system.

You may close if you wish.  But should not the system ask user to login if he is not already and if 'only my bugs' are checked?
[1 Aug 2013 7:35] Vlad Safronov
Works for me. Would you try to repeat?
[1 Aug 2013 16:47] Omer Barnir
Hi Peter,

If selecting the 'Only My Bugs' option when not logged in, the system display the message: 
   "I don't know who you are, so I can't just show your bugs. Login (link)."
and displays bugs based on the other criteria.

Thanks
==Omer