Bug #68585 EER Diagram Table arrangement gets lost. Diagram resize causes error.
Submitted: 6 Mar 2013 12:18 Modified: 5 Jul 2013 17:10
Reporter: C. Y. Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.47 CE Revision 10398 OS:Microsoft Windows (Windows 7 Home Premium)
Assigned to: CPU Architecture:Any
Tags: diagram resize, EER Diagram, information loss, table positions

[6 Mar 2013 12:18] C. Y.
Description:
After saving, closing and re-opening a model, the tables in my EER Diagram are all huddled together in the top-left corner of the diagram. The arrangement before saving is lost.
They cannot be moved freely, only horizontally. They seem to stick to the upper edge of the diagram.

When at this point I try to resize the diagram (Model -> Diagram Properties and Size...), an "MySQL Workbench Unexpected Error" window appears with the message:
"Value if '0' is not valid for 'Value'. 'Value' should be between 'Minimum' and 'Maximum'. 
Parameter name:Value

The "Notes to Developer" of the corresponding Bug Report are attached below...

How to repeat:
Open new model.
Add new EER Diagram. 
Add a new table to the diagram (table1) and "Edit Table":
- add three columns to table1: id(INT), name(VARCHAR(45)) and description(VARCHAR(255))
Add second table to diagram (table2) and "Edit Table":
- add two columns to table2: id(INT) , table1_id (INT)
- add foreign key to table2: FK_table2_table1 : foreign key table1_id  references table1(id)
Save model.
Close model.
Open model again. 
--> EER Diagram is rearranged.
Go to "Model->Diagram  properties and size..."
---> Unexpected Error occures.
[11 Mar 2013 13:58] MySQL Verification Team
Thank you for the bug report. I couldn't repeat following the how to repeat instructions. Could you please provide the model file which presents the reported behavior?. Thanks.
[15 Mar 2013 3:04] Harold Kyle
I can confirm this is always happening on schemas I edit with Windows 7. The diagram's tables will snap to the top left of the document and be uneditable afterwards. Thank goodness for backups and for my Mac laptop, which is apparently not affected by this bug. Sorry I don't have a schema to share.
[15 Mar 2013 23:13] C. Y.
The "Files" tab of this report contains the model file that produced this bug/error on my computer.
[17 Mar 2013 7:01] suhanwu su
my diagram have some table,and i add tow layer for group tables
i move table in layer ,move table out layer.after some times,the layer and table will go to top-left corner of the diagram.

i work in windows 7 64bit
[26 Mar 2013 21:57] Max Goldberg
Layers seem to cause all diagram arrangements to be lost, using the "Undo" command does not restore the arrangement.

If you create a layer with a few tables in it, and move them in and out, eventually your entire diagram will be moved to the top left.
[3 Apr 2013 15:08] Vytautas Stankus
Same here Cant work at all with EER diagram and layers even with sample project after install just move any table to other layer and everything will get mixed. It's imposible to work with layers
[3 Apr 2013 16:03] Armando Lopez Valencia
Hello.
Can you please do 2 things for us:
1. Attach a .mwb file where you can reproduce this bug.
2. Go to File->Preferences and cgheck the "Force use of software based rendering for EER diagrams".
Thanks.
[3 Apr 2013 18:23] Max Goldberg
I can confirm this still happens with software rendering on. I haven't managed to get it the entire diagram to move to 0,0 with software rendering on, but dragging between layers causes really erratic behavior and moves tables off screen or to 0,0.

Any diagram with layers seems to be able to reproduce this issue.
[4 Apr 2013 6:28] Vytautas Stankus
Armando Lopez Valencia,

for first your request I don know what else I can provide you just create any diagram with layers, move some tables to the layer and you should see problem. I even reinstalled workbench and tried with  sample diagram with goes with installation and same bug occurred.

for your second I checked and no help same problem.
I am using windows 7 Ultimate 32-bit with latest version of MySQL workbench

And don't know what to do, can't use diagrams with layers. without layers everything works fine

Maybe somewhere is error log or something I could provide that but that problem exits every time so it should be easily reproducible.
[4 Apr 2013 14:28] Armando Lopez Valencia
Apologies.
Verified with the .mwb file attached.
[11 Apr 2013 23:07] Chris Nanney
I've seen this behavior in the previous release as well, I've just gotten used to not rearranging things too much for fear everything will instantly jump to top left corner.

Here it is in action:
http://cnanney-video.s3.amazonaws.com/mysql_workbench_eer.mp4

I've only see it happen when layers were involved.
[12 Apr 2013 11:14] Mikko Torniainen
I have this happening too and I'm not using layers.
[15 Apr 2013 13:14] Dominic Dumont
I have the exact same problem here. Happens almost everytime i move a table..
[18 May 2013 18:10] Rob Lambell
Can confirm this issue on Windows 7 64 bit, making the current version unusable for EER diagrams. Issue present with the sample diagram, and any created or opened, with software rendering on or off.

Switching back to 5.2.38 CE Revision 8753 has solved this for me - I haven't tried any more recent versions in between.
[12 Jun 2013 20:01] Werner Kohaupt
Hello,

i had the same problem. I change in File -> PageSet from Portait to Landscape and now the diagramm is ok. An attempt is worth it.
[22 Jun 2013 23:04] Alfredo Kojima
There are 2 issues being mixed here, one if a duplicate of bug #68585 (the one illustrated by the video).
The other  is caused by the diagram being sized 0x0. There are validations to prevent that, so the question is how did that happen? Does creating a new diagram from scratch always get you a 0x0 diagram?
[22 Jun 2013 23:07] Alfredo Kojima
Question.. does everyone having problems with 0x0 diagram use a non-english locale, such as German?
[22 Jun 2013 23:25] Alfredo Kojima
Correction: the duplicate bug number for the mixed in issue is #68727
[23 Jun 2013 12:04] Dominic Dumont
I am having the same problem as the one in the video
My locales are so to English (United Sates).
[26 Jun 2013 1:39] Alfredo Kojima
Please try 6.0.3 when it's out
[28 Jun 2013 14:01] Rick Goodrow
can confirm that when dragging a table into / out of a layer, causes the layer + tables (some in, some out) to have their position reset to 0,0
Windows 7 x64 - MysqlWB v5.2.47 CE
[5 Jul 2013 17:10] Alfredo Kojima
You should be able to fix the size of the diagram from 0x0 to a larger value, which will fix the problem. If you get a diagram sized 0x0 again, please reopen this bug and provide details how you did that.

Other reporters complaining about layout getting messed when moving objects, please do not comment here, that is a different issue, reported in bug #68727
[7 Aug 2013 20:13] cealex alex
i had the same issue ...
the work around that i've found, and worked for me, was

go to "file" -> "page setup" and change the paper size, after that i was able to move freely the tables.
[17 Nov 2013 10:00] Walter VvF
I am experiencing the same problem described above. Whenever I'm opening a saved EER diagram, all the tables are stuck to the top left corner, can't be moved. If I resize the diagram or change the page layout, they can be moved again. But once I've saved them and open again, back to the same problem.

This appears to have changed now that I switched my locale settings from German to UK English. This may be a work-around for now, but can't really be a longterm solution.

Am running Win 7 Home. Version 6.0.8 of Workbench.
[10 Jan 2014 8:21] Lars Hesse
I am having exactly the same problems as described by Walter VvF.

I am using Win 7 Pro with Workbench 6.0.8.11354 build 833.
[6 Oct 2014 11:46] Claude Ratthé
happen to me as well, latest version (6.2.3.12312 build 2280 (64 bits)) brand new install, first try at designing a schema, create table and put on ERR diagramm, close and re-open, all the table are stuck on upper edges ..I can only move them horizontaly, even when adding new table.

on windows 7 premium
[8 Oct 2014 12:47] Иван Лапоть
I have the same problem. Windows 8.1 Prof

WORKAROUND: use Windows XP SP3 compatibility.
[24 Oct 2014 15:07] Aleksey Lisun
The problem appears in 6.2.3.12312 build 2280 (64 bits) Windows 8.1