Bug #68558 Make it possible to build with system libedit
Submitted: 4 Mar 2013 10:34 Modified: 22 Apr 2013 17:18
Reporter: Norvald Ryeng Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S4 (Feature request)
Version:5.6.10 OS:Any
Assigned to: CPU Architecture:Any

[4 Mar 2013 10:34] Norvald Ryeng
Description:
Please make it possible to specify WITH_LIBEDIT=system, or a similar option, to use the system libedit instead of the bundled library. This is how Linux distributions build their binaries.

How to repeat:
Build it.
[22 Apr 2013 17:18] Paul Dubois
Noted in 5.6.12, 5.7.2 changelogs.

A new CMake option, WITH_EDITLINE, is provided to indicate whether to
use the bundled or system libedit/editline library. The permitted
values are bundled (the default) and system.
[23 Apr 2013 12:14] Paul Dubois
Addition to changelog entry:

WITH_EDITLINE replaces WITH_LIBEDIT, which has been removed.