Bug #68511 connection cancelled in workbench when running sql development(editor)
Submitted: 27 Feb 2013 18:42 Modified: 30 May 2013 17:25
Reporter: Tim Buches Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.47 CE OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[27 Feb 2013 18:42] Tim Buches
Description:
i have had this same problem in earlier versions as well. clicking on open connection to start querying under sql development portion of workbench is hit and miss. a message displays in lower left corner of workbench screen that says connection cancelled. however i can connect everytime to vis server administration. in fact, server admin shows a connection for each connection cancelled message i get. its like the conection is made but the gui is dying. 

How to repeat:
click on a connection created under "Open Connection to Start Querying" in SQL development portion of workbench. 90% of time it states "Connection Cancelled"

Suggested fix:
connect success every time you attempt to connect!
[27 Feb 2013 18:52] Tim Buches
i tried simply clicking on the "Open Connection to Start Querying" link and then select one of the connections in the stored connection drop down and workbench crashes everytime, no matter what connection i choose. some connections have pwds stored in vault, some do not. 

i get a workbench stopped working and options to check online, close or debug program, also show details. below are the details ...

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLWorkbench.exe
  Application Version:	5.2.47.10398
  Application Timestamp:	511d76f0
  Fault Module Name:	grt.dll
  Fault Module Version:	0.0.0.0
  Fault Module Timestamp:	511d6840
  Exception Code:	c0000005
  Exception Offset:	00001a88
  OS Version:	6.1.7601.2.1.0.400.8
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
[28 Feb 2013 15:50] Tim Buches
so i got some advice from the forum to look in the log files for workbench, (click on Help , then click on Locate log files).

attached are the contents of a logile where by all i did was attempt to launch SQL Editor once workbench came up...

the sql editor gui never launched, and i viewed the message "Connection Cancelled" in bottom left corner of window.  the last 10 lines of this log states the gui came up and that the connection was cancelled by user, but i never touched the3 screen.
[28 Feb 2013 15:53] Tim Buches
workbench log file

Attachment: wb.log (application/octet-stream, text), 9.84 KiB.

[28 Feb 2013 16:12] Tim Buches
i should mention that this system i am testing is running on a vmware workstation session. the session is a w2k8x64 server that contains the latest mysql installer for windows version of the database installed. 

so i popped back out of vmware to my windows 7 host and ran workbench to connect remotely to the w2k8x64 vmware system running the mysql server and i can launch sql editor all day long, no connection cancelled messages. 

so is there an issue running mysql on a vmware session, or workbench on a vmware session???
[2 Apr 2013 15:24] Armando Lopez Valencia
Thanks a lot for your report.
[30 May 2013 14:46] Alexis Castillo
I am experiencing the same issue.

Environment:
Workbench 1
MySQL Workbench 5.2.47 CE running on Windows 7 Ultimate (it's an ESXi 5.1 Virtual Machine) accessed via Remote Desktop.

Workbench 2
MySQL Workbench 5.2.47 CE running on Windows 7 Ultimate (Laptop).

MySQL server 5.5.31-0Ubuntu0.12.04.1 running on Ubuntu 12.04.1 (it's also an ESXi 5.1 Virtual Machine).

Environment Workbench 1 does NOT work
If I try accessing the SQL Editor from the Windows 7 virtual machine, I get the connection cancelled.  At first it would connect once in a while (CPU would spike at 100% and if I closed the Workbench the CPU would return to normal).  Then I tried a few suggestions like running the Workbench window not maximized but after that the SQL Editor stopped working with the Connection Cancelled message.

Environment Workbench 2 DOES work
No problems using the SQL Editor under this environment.  CPU usage is nominal.

One test I still have to do is run the SQL Editor in Environment Workbench 1 using the ESXi console directly, thus bypassing Remote Desktop Connection to see if that makes a difference and narrows it down.
[30 May 2013 15:55] Alexis Castillo
Here's what I found out:

When I log in via the ESXi console into windows, SQL Editor starts just fine, no CPU spike, no connection cancelled.  Tried it several times and it work just fine.  Even tried different size windows and that worked too.  Left the connection open, switch from Console to RDP and it kept running just fine.  But once I closed it in RDP and tried starting it again it wouldn't start giving the usual Connection cancelled message.

My bet would be that there's something in the Workbench or SQL Editor that doesn't like being run under RDP.
[30 May 2013 17:25] Tim Buches
all of my problems went away when i quit running workbench from a virtualized desktop, ex: VMWare
[5 Jun 2013 18:39] Pat Wellington
This problem also occurs on an Amazon (EC2) virtual machine.  I do not experience when running the same version of workbench on my desktop.

On the Amazon machine I can open a server admin tab.  The SQL editor window opened once and has not work subsequently.