Bug #68416 mysql_install_db depends on generating its own cnf
Submitted: 18 Feb 2013 16:04 Modified: 9 May 2014 9:58
Reporter: Bjoern Boschman (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.6.10 OS:Linux
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D5 (Feature request)

[18 Feb 2013 16:04] Bjoern Boschman
Description:
mysql_install_db relies on creating my.cnf based on a my-default.cnf

in order to provide a custom/own this should be optional

How to repeat:
install mysql-server. delete my-default.cnf
run mysql_install_db --rpm

Suggested fix:
from my point of view my.cnf must not be created by `mysql_install_db`
[18 Feb 2013 16:37] Hartmut Holzgraefe
See also bug #68117
[19 Feb 2013 17:50] Sveta Smirnova
Thank you for the report.

Although this bug is almost same as bug #68117 I verify it separately, because your arguments are reasonable and there is a sense to not create configuration file in some environments.
[9 May 2014 9:58] Terje Røsten
Duplicate of bug#71600.