Bug #68343 Workbench crashes when importing a csv
Submitted: 12 Feb 2013 1:34 Modified: 10 Jul 2013 21:55
Reporter: Armon Rouhani Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.47 OS:MacOS (Also confirmed on Windows 7)
Assigned to: CPU Architecture:Any
Tags: import csv crash mac osx

[12 Feb 2013 1:34] Armon Rouhani
Description:
When importing a CSV file into the workbench, the application hangs for a moment and then crashes, with no errors.

How to repeat:
1) Load the attached workbench file
2) Open the PERIOD table
3) Import the attached *.csv file
[12 Feb 2013 1:36] Armon Rouhani
Issue was also present on 5.2.44 earlier.

Tested on Windows 7 x86_64 and Mac OS X 10.8.2
[19 Feb 2013 15:12] MySQL Verification Team
Thank you for the bug report.

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
   at ActionList.trigger_action(ActionList* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* )
   at MySQL.Grt.ActionList.trigger_action(String name)
   at MySQL.Grt.Db.RecordsetView.TriggerAction(String name, Object data)
   at MySQL.GUI.Workbench.WorkbenchToolbarManager.toolbarItem_Click(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripButton.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[20 Jun 2013 18:17] Alfredo Kojima
The crash is a bug, but the problem is that your data file has \r terminated lines instead of the normal \n or \r\n
Once the newlines are fixed, it can be imported OK
[10 Jul 2013 21:55] Philip Olson
Fixed as of MySQL Workbench 6.0.3 (BETA 2), and here's the changelog entry:

´╗┐Importing a CSV file that defined line endings with "\r" instead of
"\n" or "\r\n" would cause MySQL Workbench to crash. A warning message is now
displayed that warns of the incorrect format.

Thank you for the bug report.