Bug #68328 Mismatch on version of "mysqldump.exe" and "mysqld.exe" mak failure in Workbench
Submitted: 9 Feb 2013 19:34 Modified: 13 Jun 2013 5:59
Reporter: Ted palmer Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.46 OS:Microsoft Windows (Can't Export Data)
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D2 (Serious)

[9 Feb 2013 19:34] Ted palmer
Description:
I get the following error message when attempting to Export in SQL format to a file. The error message says "mysqldump.exe is version 5.5.16" will not work with version 5.6.10 of MySQL Server. When I go to Windows Explorer and navigate to "C:\Program Files\MySQL\MySQL Server 5.6\bin" and right click on file name "mysqldump.exe" the OS tells me that the version of the File and Product is 5.6.10.0. So where is MySQL Workbench getting this other version of "mysqldump.exe"?

This is really hurting me because to prepare a demo version of data for my first hopfully paying customer I have to put in the DB, . . .  I have to be able to export to SQL so that I can edit the data and re-import it to keep information protected by attorney client priviledge from being revealed.

NEVER MIND! But the installer should be fixed to set the preference correctly. This wasn't a problem for MySQL server version 5.5.23
+++++++++++++++++++

WARNING

mysqldump.exe is version 5.5.16, but the MySQL Server to be dumped has version 5.6.10-log.

Because the version of mysqldump is older than the server, some features may not be backed up properly.

It is recommended you upgrade your local MySQL client programs, including mysqldump to a version equal to or newer than that of the target server.

The path to the dump tool must then be set in Preferences -> Administrator -> Path to mysqldump Tool:

12:31:21 Dumping autosubrogatenew (casecalendaractions)

Running: mysqldump.exe --defaults-extra-file="c:\users\tlp008~1.sub\appdata\local\temp\tmp6iqm7e.cnf"  --max_allowed_packet=1G --host=127.0.0.1 --flush-logs=TRUE --user=root --flush-privileges=TRUE --port=3306 --default-character-set=utf8 "autosubrogatenew" "casecalendaractions"

mysqldump: Couldn't execute 'SET OPTION SQL_QUOTE_SHOW_CREATE=1': You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'OPTION SQL_QUOTE_SHOW_CREATE=1' at line 1 (1064)

Operation failed with exitcode 2

12:31:22 Export of C:\Drv1\Ted's_Stuff\MySQL_DumpFiles\NewDB4RWP\DumpProjectFolder\Dump20130209.sql has finished with 1 errors

How to repeat:
Run MySQL Workbench and try to export data in SQL format to a file. To do my install I downloaded the Master Installer that installs everything needed to use MySQL server 5.6.10 in one MSI file.

Suggested fix:
Figure out how MySQL Workbench is getting a different version of mysqldump.exe than the one installed with the server. Possible recompile or relink to the correct version.
[9 Feb 2013 21:46] Miguel Solorzano
Thank you for the bug report.

C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.46>mysqldump --version
mysqldump  Ver 10.13 Distrib 5.5.16, for Win32 (x86)
[11 Feb 2013 22:25] Robert ocking
I am using mysql 5.6.10 on windows 7 (64 bit) and was having exactly the same issue with the version mismatch. I downloaded the mysql-5.6.10-winx64.zip folder from this site, opened it, copied out the mysqldump.exe file and pasted it into the two mysql folders on the C: drive.
C:\Program Files\Mysql\MysqlServer 5.6\bin\ (sentence case may not be correct)
C:\Program Files(x86)\Mysql\Mysql Workbench CE 5.2.46\
restarted the Pc. and the export worked perfectly.
[11 Feb 2013 23:18] Ted palmer
Robert ocking:

I am surprised that you got the result you did for the corrective action that you took. I don't doubt that you got what you got, but that just doesn't square with what I finally read at the end of the error message. Which was

"The path to the dump tool must then be set in Preferences -> Administrator -> Path to mysqldump Tool".

That is all I did. Set the path to the "mysqldump.exe" program in the preferences. It is unfortunite that the most valuable part of the error message was at the bottom. Because I had other issues that inspired me to concentrate my efforts at what was at the top.

What you downloaded should have been the same version of what was already in the folder. In the process I stumbled on language that said that the path had to be set in the MySQL Workbench Preferences or else the version of mysqldump.exe that was linked into the executable would be used. That explained how it was that a version different than what I just installed got executed.

You might take a look the top menu choice Edit >> preferences >> Administrator. It was a shocker to me when I saw it.

Ted Palmer
[15 Mar 2013 17:21] Stephen Tregidga
Had the exact same issue (running on 64bit Win8). Thanks Robert ocking for your work-around. Worked perfectly for me also.
[23 Mar 2013 14:29] Nandan Jain
Thanks Robert ocking for your solution. I also had same issue and your solution has worked very well. It solved my problem. Thanks Again.
[23 Mar 2013 19:36] Michael Lant
I am having exactly the same problem. I cannot export/backup a database.

I installed the latest version of WB, but before doing that, I uninstalled the previous version of WB and wiped out the following folder: C:\Users\<user>\AppData\Roaming\MySQL\Workbench\

I am also experiencing that persistent "Connection Cancelled" issue whenever I attempt to open a connection to the database. MySQL Workbench has been rendered 100% unusable.

[Window Title]
MySQL Workbench

[Main Instruction]
mysqldump Version Mismatch

[Content]
mysqldump.exe is version 5.5.16, but the MySQL Server to be dumped has version 5.6.10-log.
Because the version of mysqldump is older than the server, some features may not be backed up properly.
It is recommended you upgrade your local MySQL client programs, including mysqldump to a version equal to or newer than that of the target server.
The path to the dump tool must then be set in Preferences -> Administrator -> Path to mysqldump Tool:

[Continue Anyway] [Cancel]
[4 Apr 2013 14:13] massimo carozzo
Indeed there are two problems.

1) If you do not specify the path for mysqldump.exe, the export
   is suspended and a warning is published waiting for your decision.
2) If you specify the path the warning is published in the export
   log pane but the export process starts anyway.

Obviously if you replace mysqldump.exe with correct version as suggested,
export runs without any warning.

Massimo.
[6 Apr 2013 22:54] Luis Medeiros
I've got se same problem today and solved it copying the files mysqldump*.* from "C:\Program Files\MySQL\MySQL Server 5.6\bin" to "C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.47"

BTW: I'm using Win 7 Ultimate 64 bits
[21 Apr 2013 0:32] Bob Tschetter
I did what Ted suggested except that Luis actually provided the location of the correct dump.exe file.

Here's what I did, and I have Windows 7 64 bit too.

Edit, Preferences, Administrator
Selected path to mysql dump tool: C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqldump.exe

Notice the correct *dump.exe file is in bin folder of c:\Program Files\... not c:\Program files x86\... 

I ran the export and got no errors...finally!
[21 Apr 2013 17:54] Ted Palmer
Thank you for keeping me informed guys. I appreciate all that you do. But may I suggest this. One of the fixes offered was to update the MySQL utility software on my PC to be at or above the version of the MySQL server the utility software is working with. I experienced this using the whole MySQL software package that I had just downloaded that day. If there is a mismatch in versioning between programs in the download package, it seems to me that the download package that provides the all the software a user needs to use MySQL on windows needs to be revised.

Ted Palmer
[24 Apr 2013 1:27] Jack Worthing
Bob's comment worked great for me!

Thanks Bob
[20 May 2013 9:36] Louise Wheatley
Thank you Robert and Bob.  I had two different versions of mysqldump.exe. Setting the preferences to the one in Program Files not Program Files (x86) worked. Thanks Ted for raising it.
[23 May 2013 5:35] Junior Granados
to solve this problem go to workbench program:
edit>>preferences>>administrator>>path to mysqldump tool:>>  choose C:\programfiles\MySQL\MySQL Server 5.6\bin\mysqldump.exe
press ok.

in that way choose the same version of mysqldump.exe 5.6.11 from the server folder.

:) hope you like it
[6 Jun 2013 16:30] Christopher Hinkle
I followed the workaround suggested and specified the location of mysqldump.exe (which I confirmed to be version 5.6.11 by looking at the file properties).  When I then continued with the dump, I no longer received the pop-up notice, but I did get the following in the Export Progress tab's Log window: 

WARNING

mysqldump.exe is version 5.5.16, but the MySQL Server to be dumped has version 5.6.11-log.

Because the version of mysqldump is older than the server, some features may not be backed up properly.

It is recommended you upgrade your local MySQL client programs, including mysqldump to a version equal to or newer than that of the target server.

The path to the dump tool must then be set in Preferences -> Administrator -> Path to mysqldump Tool:

12:25:16 Dumping my_database (all tables)

Running: "C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqldump.exe" --defaults-extra-file="c:\users\username\appdata\local\temp\3\tmpj0edbv.cnf"  --user=root --max_allowed_packet=1G --host=localhost --port=2222 --default-character-set=utf8 --routines --events "my_database"

12:25:18 Export of T:\backup\20130606.sql has finished
---------
I note that the path to mysqldump.exe mentioned on the "Running:" line is the exact same one I set in the preferences tab and which I confirmed to be version 5.6.11.
[6 Jun 2013 16:39] Christopher Hinkle
Adding to the above comment under name "NOT_FOUND", my version of MySQL Workbench is 5.2.47 CS Revision 10398 running on Windows Server 2012.
[13 Jun 2013 5:59] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.0.2 public beta release, and the changelog entry was merged with Oracle Bug #16575396 / MySQL Bug #68683 which reads as:

An older version of the MySQL Client was bundled with MySQL Workbench, and it
has since been updated. This caused problems while executing "mysqldump".

Thank you for the bug report.
[23 Jul 2013 11:32] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=69819 marked as duplicate of this one.
[21 Aug 2013 0:30] Alejandro Garro
/Applications/MySQLWorkbench.app/Contents/MacOS/mysqldump is version 5.5.24, but the MySQL Server to be dumped has version 5.6.12.
Because the version of mysqldump is older than the server, some features may not be backed up properly.
It is recommended you upgrade your local MySQL client programs, including mysqldump to a version equal to or newer than that of the target server.
The path to the dump tool must then be set in Preferences -> Administrator -> Path to mysqldump Tool: