Bug #68304 MySQL for Excel Append Excel Data to table
Submitted: 7 Feb 2013 17:09 Modified: 5 Aug 2013 21:30
Reporter: Karen Ackroyd Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version: OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[7 Feb 2013 17:09] Karen Ackroyd
Description:
MySQL for Excel Append Excel Data to table returns 'An Error Occurred Column not found'

I have created a database using MySQL Workbench. I wish to import data from sheets in Excel workbook. Sometimes this works and other times it fails. This may be triggered by dropping and re-creating the database.

I am able to insert data into the table from the MySQL command line client and I have checked the database using mysqlcheck.

I can send the sql generated by MySQL workbench if required.

How to repeat:
I can send the sql generated by MySQL workbench to repeate the bug.
[7 Feb 2013 17:11] Karen Ackroyd
File containing sql to generate database

Attachment: stc_lab_inventoryLatest.sql (text/plain), 21.99 KiB.

[8 Feb 2013 16:03] MySQL Verification Team
Could you please provide a screen-shot of the error message and provide the Excel version. Thanks.
[14 Feb 2013 11:51] Karen Ackroyd
The problem is caused by the following sequence of events (details in attached files).
See attached files for example.
1. Import data from a databse table to Excel.
2. Append Excel Data to Table and Store Mapping.
3. Change column names in one of the exported tables (e.g. ALTER TABLE director CHANGE `Last Name' last_name varchar(45);).
4. Repeat 2. At this point as the mapping is now incorrect an error screen pops up. This prevents access to the Append screen so you are unable to clear or delete the (now incorrect) mapping. 
5. A work round is to choose a different table to export and on reaching the Append screen delete the incorrect mapping.
[14 Feb 2013 11:54] Karen Ackroyd
database creation schema

Attachment: movies.sql (application/octet-stream, text), 3.07 KiB.

[14 Feb 2013 11:54] Karen Ackroyd
Excel data

Attachment: movies.xlsx (application/vnd.openxmlformats-officedocument.spreadsheetml.sheet, text), 8.19 KiB.

[5 Aug 2013 21:30] Javier TreviƱo
Tried to reproduce the problem in the latest 1.1.1 version following the given steps, but could not reproduce it.  Tried changing the name of columns of the target table using MySQL Workbench.  Every time the Append Data window opened without any errors.

Please supply a more detailed set of steps using the latest MySQL for Excel version. Also if possible include the log file found at %appdata%\Oracle\MySQL for Excel.

Thanks for your interest in MySQL for Excel.