Bug #68267 mySQL service start error 1067
Submitted: 5 Feb 2013 2:40 Modified: 8 Feb 2013 19:36
Reporter: Viney Ugave Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.6 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[5 Feb 2013 2:40] Viney Ugave
Description:
I am getting the following error while starting the mysql service - Error 1067 and here is the error log : 

InnoDB: Reading tablespace information from the .ibd files...
130204 19:20:28 [ERROR] InnoDB:  InnoDB: Error: Attempt to open a tablespace previously opened.
Previous tablespace cesdata/loginlog uses space ID: 2 at filepath: .\cesdata\loginlog.ibd
Cannot open tablespace mysql/innodb_index_stats which uses space ID: 2 at filepath: .\mysql\innodb_index_stats.ibd

InnoDB: Error: could not open single-table tablespace file .\mysql\innodb_index_stats.ibd
InnoDB: We do not continue the crash recovery, because the table may become
InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it.
InnoDB: To fix the problem and start mysqld:
InnoDB: 1) If there is a permission problem in the file and mysqld cannot
InnoDB: open the file, you should modify the permissions.
InnoDB: 2) If the table is not needed, or you can restore it from a backup,
InnoDB: then you can remove the .ibd file, and InnoDB will do a normal
InnoDB: crash recovery and ignore that table.
InnoDB: 3) If the file system or the disk is broken, and you cannot remove
InnoDB: the .ibd file, you can set innodb_force_recovery > 0 in my.cnf
InnoDB: and force InnoDB to continue crash recovery here.

Can anyone please explain what is wrong with my database "cesdata"  ???
can anyone please help me with this ??

How to repeat:
Any change in the files system on the drive .
[5 Feb 2013 6:50] Erlend Dahl
This is a known issue that is fixed in 5.6.10, due to be released shortly.

There is a suggested workaround in bug#67595 you could try (comment [27 Nov 2012 8:39] Bains Jaspreet), but I'm not sure if that will work in your situation.

Marked as duplicate of bug#67179
[5 Feb 2013 18:01] Viney Ugave
Yea I ll try that but can you tell me what is the reason behind this behavior and how can it be avoided ... Can you tell me tentative date of the new release ?? Is there a way I can back up my databases and use them in a new installation of 5.6 or 5.5 ??? Can you direct me to any resources of the same ..
[6 Feb 2013 4:19] Erlend Dahl
5.6.10 has just been released, please give that a try.
[6 Feb 2013 4:28] Viney Ugave
Should I upgrade the existing MySQl 5.6  installation ??
[6 Feb 2013 12:44] Erlend Dahl
If you have an existing 5.6 installation (using one of the pre-GA releases), my advice is to use mysqldump as described in 

  http://dev.mysql.com/doc/refman/5.6/en/copying-databases.html

to save your data, then start with a fresh install of 5.6.10 and restore your data into that.

There is no guarantee that a direct upgrade from a pre-GA version to a GA version will work.
[7 Feb 2013 22:11] Viney Ugave
No the upgrade didnt work .. can you tell me what can I do to restore my database files in another windows machine .I have an important INNODB database in it which i need to restore ... I have the data folder which contains the .frm and .ibd files .... 

Please help I need a solution asap ...
[8 Feb 2013 19:36] Viney Ugave
Anyways I recovered all my files this way ... this works great ..please try this : 

http://www.nerdydork.com/restoring-mysql-innodb-files-on-windows.html

The bug has been sorted in the latest version ...
[14 Jun 2016 9:16] Bhupesh Pant
I am also getting the same error. Can someone from the support team explain what was the reason behind this?
[14 Jun 2016 17:44] Bhupesh Pant
I wanted to know what has caused this issue, not how can we fix it?  

I am able to fix this issue by setting up,
 [mysqld]
innodb_force_recovery = 1 

I