Bug #68257 Importing a model in SQL format result in two models in the catalog tree.
Submitted: 3 Feb 2013 4:14 Modified: 3 Jun 2013 19:03
Reporter: Fotis Kokkoras Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.45 OS:Microsoft Windows (v.7/64bit, updated)
Assigned to: CPU Architecture:Any
Tags: catalog tree
Triage: Needs Triage: D3 (Medium)

[3 Feb 2013 4:14] Fotis Kokkoras
Description:
Importing a previous exported database model (in SQL format) in the model designer result in two models in the catalog tree, the one loaded and the default mydb. The later must be removed.

How to repeat:
1. You need to have a previously created database model in slq format. Any simple moled is adequate. Just give it a name different than the default "mydb".
2. Start Wotkbench and create a new ERR model
3. Select File > Import > Reverse Engineer MySQL Create Script...
4. Press the Browse button and select the model described in step 1.
5. Check the 'Place imported objects on a diagram" checkbox and press the Execute button.
6. You end up with two databases in the Catalog Tree. The one loaded and the usual "mydb".
[4 Feb 2013 13:42] Miguel Solorzano
Thank you for the bug report. Verified as described having as work-around to delete the mydb schema.
[3 Jun 2013 18:34] Alfredo Kojima
This is not a bug, importing an external schema into a model, should not automatically DROP existing schemas from the model.
[3 Jun 2013 19:03] Fotis Kokkoras
How am I supposed then to switch between the two models in the graphical editor?