Bug #68080 MySQL Workbench keeps crashing on Mac Mountain Lion
Submitted: 14 Jan 2013 12:07 Modified: 13 Aug 2013 21:50
Reporter: Oliver Drummond Oliver Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.47 OS:Mac OS X (10.8.3)
Assigned to:
Tags: all the time, crash, mac, mountain lion, right click

[14 Jan 2013 12:07] Oliver Drummond Oliver
Description:
Everytime I use MySQL Workbench (Version 5.2.45) on my Mac (With OS X 10.8.2) it keeps crashing ALL THE TIME.	

How to repeat:
Sometimes, I simply open a connection and try to select rows from a table. Pretty much anything that I do crashes the software. Already tried toreinstall it, but it keeps crashing
[16 Jan 2013 14:21] Ruben Dario Morquecho Valdez
Could you please provide details/steps when it crashes?, is there specific steps when always crash?, in order to reproduce it.

Thank you for your interest in MySQL.
[28 Jan 2013 13:09] Steve Attwell
I have exactly the same issue. Steps to reproduce are open MySQL Workbench, connect to the database and then crash will happen randomly on any operation about 10 to 15 seconds later. Examples are opening a query window, right clicking on a table in the left nav window, looking at the contents of a table. I have uninstalled and reinstalled MySQL Workbench probably 10 times. Other MySQL clients work fine eg.Navicat, SQL Developer, Razor, Sequel.

Process:         MySQLWorkbench [20054]
Path:            /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
Identifier:      com.oracle.mysql.workbench
Version:         5.2.45 (1)
Code Type:       X86 (Native)
Parent Process:  launchd [237]
User ID:         502

Date/Time:       2013-01-28 08:05:56.408 -0500
OS Version:      Mac OS X 10.8.2 (12C60)
Report Version:  10

Interval Since Last Report:          631732 sec
Crashes Since Last Report:           10
Per-App Interval Since Last Report:  212527 sec
Per-App Crashes Since Last Report:   5
Anonymous UUID:                      EED42192-E52C-78DC-7496-FF3B337C1D71

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000e0e44e1b

VM Regions Near 0xe0e44e1b:
    CG backing stores      00000000cb2fd000-00000000cb805000 [ 5152K] rw-/rw- SM=SHM  
--> 
    VM_ALLOCATE            00000000fefff000-00000000ff000000 [    4K] rw-/rwx SM=PRV
[10 Mar 2013 17:55] Oliver Drummond Oliver
Video of the error happening

Attachment: MySQL Error.mp4 (video/mp4, text), 593.27 KiB.

[10 Mar 2013 17:55] Oliver Drummond Oliver
This error still happens with version 5.2.47.
[13 Mar 2013 9:58] Graham Charlton
I have the same problem. It appears only to happen if, like Oliver Drummond's video, I right click the table name and choose 'Select Rows'. If I compose the query in the browser or restart after the crash with the query that was auto pasted into the browser, and click the execute button all works ok.

I too have had this problem since version 5.2.45 and it persists in 5.2.47.

Graham.
[14 Mar 2013 15:01] Cristhian Parra
I have the same problem running version 5.2.45 on Mac OS X 10.8.2
[25 Mar 2013 12:19] Oliver Drummond Oliver
I've just installed version 5.2.40 and had absolutelly no problem with it. (The problem persists on 45, 46 and 47.
[28 Mar 2013 20:17] Steve Attwell
I also tried 5.2.40 and have had no problems.
[11 Jun 2013 19:46] Douglas Maske
Trying to edit a table, ssh'd into a CentOS 6.4 machine running MySQL 5.6.12-1.  My Mac is OS X 10.8.4 running Workbench 5.2.47.

Attachment: sqlcrash.txt (text/plain), 68.21 KiB.

[10 Jul 2013 1:09] Tom NOT_FOUND
I am using OS X 10.8.4, MySQL Workbench 5.2.47.

I have been using MySQL Workbench fine for months and just tonight it crashes every time I open it. I open a connection and if I try to query a table either through a query or through the built in 1000 row utility, it instantly crashes. This is a huge problem. I love MySQL but this is a show stopper.
[19 Jul 2013 9:06] Graham Charlton
I'm currently trying Workbench Beta V6.0.3. I have the same problems as since 5.2.40 and have realised that the problem is not db interaction but user interface. If I right click in the left pane it crashes. If I try to export query results using the export recordset icon, it crashes. If I try and save a script to file, again it crashes. If I write queries and execute them from the main window, I don't have a problem.

Interestingly, when I restart and try and do the thing that caused the crash, it works fine until I do something different to make it crash.

Graham
[23 Jul 2013 11:33] Graham Charlton
As an addendum to my last note, I'm running the same versions of workbench on a Macbook Air, same version of OS X (10.8.4) and everything works with no crashes.

Graham.
[23 Jul 2013 11:56] Graham Charlton
Ooops! It just crashed on the Macbook Air for the first time, so please ignore previous post.

Graham.
[1 Aug 2013 8:01] Graham Charlton
These posts don't seem to be going anywhere, however:

I have noticed that normally the sort order in the left pane is alphabetical, but just before a crash, the order changes, showing, for example, the most recently changed objects at the top of the list. Closing the schema and re-opening without quitting workbench then re-orders the list.

Graham.
[13 Aug 2013 21:50] Oliver Drummond Oliver
Unfortunately, same thing still happening with version 6.0.6 on Mac...

So, any news about this annoying bug?
[3 Sep 2013 15:55] ines vidal
Same issue here, never managed to start the programm
[3 Sep 2013 15:55] ines vidal
log for the crash

Attachment: mysql6.0.7.rtf (text/rtf), 31.92 KiB.

[20 Oct 2013 19:27] Jean-Claude Stritt
Is this bug now corrected ? I have the same crash symptoms with release 6.0.7. Very critical for me.
[25 Nov 2013 9:30] Gustavo Jantsch
For me it happens any time when I'm trying to connect to the DB through a SSL tunnel on version 6.0.8.11354 build 833 Communitiy edition.
[25 Nov 2013 9:35] Gustavo Jantsch
Dump file of the error.

Attachment: mysqlworkbench.txt (text/plain), 58.35 KiB.

[15 Dec 2013 14:02] Sohail Aboobaker
I have the same issue. It keeps crashing intermittently. Was there any progress on this bug? I am using 6.0.7.
[8 Jan 2014 19:16] Alfredo Kojima
This crash is caused by a bug in SCFinderPlugin
Deleting it should make WB (and many other apps affected by it) work fine again.
[13 Jan 2014 10:18] Graham Charlton
I don't have any plug-ins installed so SCFinderPlugin is not the reason for my installation crashing.
[13 Jan 2014 10:39] Graham Charlton
I was talking out of my hat with the last post - I did have an old version of SCPlugin (Tigris Subversion) which I've removed. I will test and confirm whether this has fixed Workbench for me.
[14 Jan 2014 9:33] Graham Charlton
Having removed old SCPlugin, WB hasn't crashed at all, so thank you Alfredo Kengi Kojima for solving the problem.