Bug #68020 Workbench unstable/crashes consistently on Ubuntu 12.04 (64bit)
Submitted: 3 Jan 2013 11:29 Modified: 16 Jan 2013 18:41
Reporter: Martin Gunther Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:5.2.45 OS:Microsoft Windows (7)
Assigned to:
Tags: crash, editor, ubuntu, workbench

[3 Jan 2013 11:29] Martin Gunther
Description:
MySQL workbench since I've started using it on Ubuntu in June has been unstable and crash. I've searched around cleared out my ~/.mysql/workbench/ folder after hunting round for solutions, but still the problem persists.

I use SSH tunnelled (from workbench) for this to happen.

I also get lock ups and slowdowns, etc. Never had these issues with Navicat on Windows to this extent.

(Also annoyingly went to report it from the program and login failed even though account works...)

MySQL Workbench CE for Linux/Unix version 5.2.45  revision 10251
Configuration Directory: /home/username/.mysql/workbench
Data Directory: /usr/share/mysql-workbench
Cairo Version: 1.10.2
OS: Linux 3.2.0-35-generic
CPU: 4x Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz 3301.000 MHz, 7.7 GB RAM
Distribution: Ubuntu 12.04.1 LTS

How to repeat:
This is one of the things that ALWAYS crashes the program, but it crashes lots of other ways too...

Connect to a server, query some data:

SELECT * FROM table WHERE id = 65; // For example
Select a blob or text and open in editor (largish value, in this case it's a chunk of HTML). Press apply, and it just crashes (dissapears from screen).

Below is output at crash time when running from the CLI:

 mysql-workbench 
Initializing AdvancedSidebar factory method
Initializing mforms factory
Creating WBOptions
Ready.

** Message: overview.home built-in command is being overwritten
Thread started
INFO: Connecting to SSH server at x.x.x.x using key <keyfile>...
INFO: Connection opened

(mysql-workbench-bin:8995): glibmm-ERROR **: 
unhandled exception (type std::exception) in signal handler:
what: Can't save value of this data type.

Trace/breakpoint trap (core dumped)

Suggested fix:
Fix it?!
[3 Jan 2013 12:40] Martin Gunther
I've just installed Workbench latest version on my Windows 7 Virtual Machine, and the same problem happens when using the editor for the same value. 

Please fix, as it's just not fit for purpose other wise.
[16 Jan 2013 18:41] Rafael Antonio Bedoy Torres
Hello Martin,
I can't reproduce your bug, can you please let us know how big is the data you are trying to open in the editor?

Will be great if you can copy and paste the data here.

Thanks in advance!
[27 Feb 2014 22:15] Puneet Arora
For me I am using ubuntu 12.04 LTS. 
Any amount of data will crash the MYSQL workbench.

STEPS TO RE-PRODUCE:
open work bench.
open you database.
Type a new Query (For me : SELECT * FROM POSITIONS;)
Run Query.
It shows the DATA.
Click inside the editor to edit query.

EXPECTED:
it should not crash or not give any error.

ACTUAL:
It closes and crash with the following error.
ERROR:
insticator@ubuntu:~$ mysql-workbench
Ready.

** Message: /usr/share/mysql-workbench/extras
/usr/bin/mysql-workbench-bin: symbol lookup error: /usr/bin/mysql-workbench-bin: undefined symbol: _ZN7pcrecpp2RE4InitEPKcPKNS_10RE_OptionsE