Bug #67945 System Profile not saving and truncation issue when Installation Type is Custom
Submitted: 19 Dec 2012 2:45 Modified: 13 Jun 2013 2:24
Reporter: John Porter Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.47 CE OS:Microsoft Windows (Windows 7 64-bit)
Assigned to: CPU Architecture:Any
Tags: command, sudo, truncation

[19 Dec 2012 2:45] John Porter
Description:
I am seeing an issue where settings aren't saved or truncated.

This is very annoying because the "sudo command" setting is something like this:

/usr/bin/sudo -p mypassword /bin/sh -c

It seems to be saved as:
/usr/bin/sudo -p mypasswor /bin/sh -c

Which means anything that requires sudo will not work.

In addition, "Installation type" keeps reverting to "custom", even though I have set it to Ubuntu (Vendor) if I select/change the my.cnf file.

How to repeat:
1. Create a connection to a remove server using a ssh tunnel.
2. Click "Manage server instances" and select the connection we just created.
3. Change the installation type to Ubuntu (Vendor).
4. Change the configuration file (in my case, /etc/MySQL/my.cnf/ to /etc/MySQL/debian.cnf).
5. See that the configuration reverts to custom.
6. Set up the "sudo command" by replacing "EnterPasswordHere" with your password.
7. Click close.
8. Click "Manage server instances" and go to our connection.
9. Look at "sudo command" and observe that the password is now truncated.

Suggested fix:
Password should not be truncated.

Allow us to choose a custom my.cnf file when using the "Ubuntu (Vendor)" installation type.
[22 Mar 2013 20:26] Armando Lopez Valencia
Hello.
This has been fixed in 5.2.47. Please give it a try and let us know if you can still reproduce the problem.
Thanks.
[24 Mar 2013 3:28] John Porter
I am still seeing the password truncation in sudo command field. However, it seems to be just a cosmetic issue and commands that require sudo seems to work fine.
[25 Mar 2013 15:48] Armando Lopez Valencia
Thanks a lot for your report.
I can see this behavior when I use a password that ends with a "0" character at the end.
Verified in:
Windows 7x64
WB 5.2.47 rev.10398
[13 Jun 2013 2:24] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.0.2 public beta release, and here's the changelog entry:

The "Sudo command" option was removed from the "Manage Server
Connections", "Server Profile" "MySQL Management" tab. 

Previously, the sudo password could be truncated.

Thank you for the bug report.