Bug #67917 MySql service fails to start with InnoDB
Submitted: 16 Dec 2012 18:02 Modified: 19 Nov 2017 17:45
Reporter: Vivek Sethi Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Storage Engines Severity:S2 (Serious)
Version: OS:Microsoft Windows (7 professional x64)
Assigned to: CPU Architecture:Any
Tags: innodb, MySQL, service

[16 Dec 2012 18:02] Vivek Sethi
Description:
I tried to install MySql 5.5 64-bit version on my machine. If I did a typical install using all the default options, I wasn't able to install it properly as the installer stuck(hangs) on the instance configuration stage. It writes my.ini file successfully but fails to start the MySql service. I tried to manually start the service, but windows could not start the service.

When I did a custom advanced install, using non-transactional database, it got installed properly but with default storage engine as MYISAM. I tried to reconfigure the instance but again, I wasn't able to get it properly installed using multifunctional database option. (Again the same problem: It did write my.ini successfully, but unable to start the MySql windows service)

I tried re-installing by removing all traces of MySql from default install location, datapath, appdata->roaming, registry.. everywhere.. but again the same problem occurred. I just can't switch to INNODB.

Any workarounds?

How to repeat:
Doing a clean uninstall and re-install of mysql server.
[16 Dec 2012 19:35] Miguel Solorzano
Thank you for the bug report. Please open a command prompt running it as administrator and perform the command: sc qc service_name .

change service_name by the service name you selected in the install process, print here the output. You will see something like:

d:\dbs>sc qc mysql55
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: mysql55
        TYPE               : 10  WIN32_OWN_PROCESS
        START_TYPE         : 3   DEMAND_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : "C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld" --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.5\my.ini" MySQL55
        LOAD_ORDER_GROUP   :
        TAG                : 0
        DISPLAY_NAME       : MySQL55
        DEPENDENCIES       :
        SERVICE_START_NAME : NT AUTHORITY\NETWORK SERVICE
[16 Dec 2012 19:46] Vivek Sethi
here:

C:\>sc qc MySql
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: MySql
        TYPE               : 10  WIN32_OWN_PROCESS
        START_TYPE         : 2   AUTO_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : "C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld
" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.5\my.ini" MySQL
        LOAD_ORDER_GROUP   :
        TAG                : 0
        DISPLAY_NAME       : MySQL
        DEPENDENCIES       :
        SERVICE_START_NAME : LocalSystem
[16 Dec 2012 19:49] Vivek Sethi
my.ini file

Attachment: my.ini (application/octet-stream, text), 8.71 KiB.

[17 Dec 2012 17:47] Miguel Solorzano
Please print here the error message when starting the server with the below command in command prompt:

"C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld
" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.5\my.ini" --standalone --console
[20 Dec 2012 6:46] Vivek Sethi
here you go:

C:\Windows\system32>"C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld" --defau
lts-file="C:\Program Files\MySQL\MySQL Server 5.5\my.ini" --standalone --console

121220 12:00:05 [Note] Plugin 'FEDERATED' is disabled.
121220 12:00:05 InnoDB: The InnoDB memory heap is disabled
121220 12:00:05 InnoDB: Mutexes and rw_locks use Windows interlocked functions
121220 12:00:05 InnoDB: Compressed tables use zlib 1.2.3
121220 12:00:05  InnoDB: Error: unable to create temporary file; errno: 2
121220 12:00:05 [ERROR] Plugin 'InnoDB' init function returned error.
121220 12:00:05 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

121220 12:00:05 [ERROR] Unknown/unsupported storage engine: INNODB
121220 12:00:05 [ERROR] Aborting

121220 12:00:05 [Note] C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld: Shutd
own complete

PS: I have reconfigured the instance and selected multifunctional database now, and the corresponding my.ini generated is attached below..
[20 Dec 2012 6:49] Vivek Sethi
my.ini (with innoDB as default engine)

Attachment: my.ini (application/octet-stream, text), 8.71 KiB.

[21 Dec 2012 13:51] Shane Bester
"InnoDB: Error: unable to create temporary file; errno: 2"

Is your temporary directory writable?
I suggest you create a directory c:\mytmp and add this to [mysqld] section of my.ini:

tmpdir=c:/mytmp

And disable antivirus from scanning that directory.
[22 Jan 2013 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[29 Jan 2016 0:10] Paris Qian
I have similar issue, same error message and whatever you mentioned does not work.
[13 Jun 2016 9:00] Anup Ghosh
Faced same issue and this solution worked for me
[19 Nov 2017 17:47] Miguel Solorzano
I couldn't repeat with current release.
[11 Jun 2018 19:03] Alexandr Pad
2018-06-11T12:29:28.381397Z 0 [ERROR] InnoDB: Unable to create temporary file; errno: 0
2018-06-11T12:29:28.383397Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2018-06-11T12:29:28.386397Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2018-06-11T12:29:28.389397Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2018-06-11T12:29:28.391397Z 0 [ERROR] Failed to initialize builtin plugins.
2018-06-11T12:29:28.394397Z 0 [ERROR] Aborting 
such mistakes may is typical, but i think may be is better to use not last version of mysql. I tried a lot of ways, but i thiked that to update will be better in my case. Can't install mysql properly, but other components i install. I will see documentation but may be in not all cases is typical problems. We had all a lot of versions of windows.