Bug #67699 mysqlbinlog --version information is outdated
Submitted: 25 Nov 2012 9:05 Modified: 25 Nov 2012 20:55
Reporter: Justin Swanhart Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.6.8-rc OS:Any
Assigned to: CPU Architecture:Any
Tags: mysqlbinlog, version

[25 Nov 2012 9:05] Justin Swanhart
Description:
mysqlbinlog should report a version and also the version that it was released at.  I need to detect if the installed mysqlbinlog is new (ie, came with 5.6) because 5.6 adds important new features like properly decoding the DECIMAL data type when displaying RBR events.  

Ideally, mysqlbinlog and the other mysql utilities should get updated version numbers when features change or bugs are fixed.

-- MySQL 5.1 --

$ mysql --version
mysql  Ver 14.14 Distrib 5.1.62, for pc-linux-gnu (i686) using readline 5.1

$ mysqlbinlog --version
mysqlbinlog Ver 3.3 for pc-linux-gnu at i686

-- MySQL 5.5 --
$ mysql --version
mysql  Ver 14.14 Distrib 5.5.28, for Linux (i686) using readline 5.1

$ mysqlbinlog --version
mysqlbinlog Ver 3.3 for Linux at i686

-- MySQL 5.6 --
$ mysql --version
mysql  Ver 14.14 Distrib 5.6.8-rc, for Linux2.6 (x86_64) using EditLine wrapper

$ mysqlbinlog --version
mysqlbinlog Ver 3.3 for Linux at x86_64

How to repeat:
Use the --version option to mysqlbinlog.

Suggested fix:
At least add the Distrib information to the mysqlbinlog output.  A better idea would be to actually properly version the utilities.
[25 Nov 2012 10:48] Shane Bester
Related: http://bugs.mysql.com/bug.php?id=55885
[25 Nov 2012 18:40] Valeriy Kravchuk
See also bug #67643 (this one can be declared a duplicate of that), bug #31142 (related feature request I've verified 5+ years ago) and bug #55885 (another related feature request that suggests to remove separate version number entirely).

Time to do something before 5.6 GA, no?
[25 Nov 2012 20:55] Miguel Solorzano
Please see prior comments. Thanks.