Bug #67617 MySQL Notifier autofilter not auto finding running services
Submitted: 16 Nov 2012 17:38 Modified: 24 May 2013 5:27
Reporter: Andrew Ramsay Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: MySQL Notifier Severity:S3 (Non-critical)
Version:1.0.3 OS:Microsoft Windows (win7x64 Home Premium)
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[16 Nov 2012 17:38] Andrew Ramsay
Description:
Notifier, after a successful install appears to have three problems:
1. fails to run on windows startup (after option is selected);
2. when running it fails to detect mysql instance
UAC is disabled

installation log below -

Action 11:34:30: INSTALL. 
1: MySQL Notifier 1.0.3 2: {5681C7AB-E29D-4EE9-B0F0-809A28ECECFC} 
Action 11:34:30: FindRelatedProducts. Searching for related applications
Action 11:34:30: AppSearch. Searching for installed applications
Action 11:34:30: LaunchConditions. Evaluating launch conditions
Action 11:34:30: ValidateProductID. 
Action 11:34:30: CostInitialize. Computing space requirements
Action 11:34:31: FileCost. Computing space requirements
Action 11:34:31: CostFinalize. Computing space requirements
Action 11:34:31: InstallValidate. Validating install
Min: 0 Max: 157
Position: 25
Position: 50
Position: 75
Position: 100
Position: 100
Action 11:34:31: RemoveExistingProducts. Removing applications
Action 11:34:31: InstallInitialize. 
Action 11:34:32: ProcessComponents. Updating component registration
Position: 100
Action 11:34:32: GenerateScript. Generating script operations for action:
Position: 101
Position: 102
Updating component registration
DoStep
Position: 103
Position: 104
Position: 105
Position: 106
Action 11:34:32: UnpublishFeatures. Unpublishing Product Features
Action 11:34:32: RemoveRegistryValues. Removing system registry values
Action 11:34:32: RemoveShortcuts. Removing shortcuts
Action 11:34:32: RemoveFiles. Removing files
Action 11:34:32: RemoveFolders. Removing folders
Action 11:34:32: CreateFolders. Creating folders
Folder: Creating folders
DoStep
Position: 107
Position: 108
Position: 109
Action 11:34:32: InstallFiles. Copying new files
File: Copying new files,  Directory: ,  Size: 
DoStep
Position: 110
Position: 111
Position: 112
Position: 113
Position: 114
Position: 115
Position: 116
Position: 117
Position: 118
Position: 119
Position: 120
Action 11:34:32: CreateShortcuts. Creating shortcuts
Shortcut: Creating shortcuts
DoStep
Position: 121
Position: 122
Position: 123
Position: 124
Action 11:34:32: WriteRegistryValues. Writing system registry values
Key: Writing system registry values, Name: , Value: 
DoStep
Position: 125
Position: 126
Position: 127
Position: 128
Position: 129
Action 11:34:32: RegisterUser. Registering user
Action 11:34:32: RegisterProduct. Registering product
Registering product
DoStep
Position: 130
Position: 131
Position: 132
Position: 133
Position: 134
Action 11:34:32: PublishFeatures. Publishing Product Features
Feature: Publishing Product Features
DoStep
Position: 135
Position: 136
Action 11:34:32: PublishProduct. Publishing product information

DoStep
Position: 137
Position: 138
Position: 139
Position: 140
Position: 141
Position: 142
Position: 143
Position: 144
Action 11:34:32: InstallFinalize. 
Min: 0 Max: 1757482
Position: 1757482
Action 11:34:33: ProcessComponents. Updating component registration
Step: 24000
Position: 0
Position: 0
Action 11:34:33: CreateFolders. Creating folders
Folder: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\MySQL\MySQL Notifier 1.0.3\
DoStep
Folder: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\MySQL\
DoStep
Action 11:34:33: InstallFiles. Copying new files
File: COPYING,  Directory: C:\Program Files (x86)\MySQL\MySQL Notifier 1.0.3\,  Size: 20018
Position: 20018
File: MySQLNotifier.exe,  Directory: C:\Program Files (x86)\MySQL\MySQL Notifier 1.0.3\,  Size: 635392
Position: 655410
File: MySQL.Utility.dll,  Directory: C:\Program Files (x86)\MySQL\MySQL Notifier 1.0.3\,  Size: 37376
Position: 692786
File: README,  Directory: C:\Program Files (x86)\MySQL\MySQL Notifier 1.0.3\,  Size: 1061
Position: 693847
File: Release Notes.txt,  Directory: C:\Program Files (x86)\MySQL\MySQL Notifier 1.0.3\,  Size: 1075
Position: 694922
Action 11:34:33: CreateShortcuts. Creating shortcuts
Shortcut: Notifier.ico
DoStep
Shortcut: fou1zoqo.3|MySQL Notifier 1.0.3
DoStep
Action 11:34:33: WriteRegistryValues. Writing system registry values
Step: 13200
Position: 694922
Key: \Software\MySQL AB\MySQL Notifier 1.0.3, Name: installed, Value: #1
DoStep
Position: 694922
Key: \Software\MySQL AB\MySQL Notifier 1.0.3, Name: location, Value: C:\Program Files (x86)\MySQL\MySQL Notifier 1.0.3\
DoStep
Action 11:34:33: RegisterProduct. Registering product
Position: 1683082
{5681C7AB-E29D-4EE9-B0F0-809A28ECECFC}
DoStep
Action 11:34:33: PublishFeatures. Publishing Product Features
Feature: Complete
DoStep
Action 11:34:33: PublishProduct. Publishing product information
Action 11:34:33: RollbackCleanup. Removing backup files
1: MySQL Notifier 1.0.3 2: {5681C7AB-E29D-4EE9-B0F0-809A28ECECFC} 3: 1 

How to repeat:
1. install notifier from mysqlinstaller 5.6.7 rc2.
2. run manually (it doesn't start automatically).
3. right-click icon in system tray, select Options, and tick "Run at Windows Startup", then click apply - reboot to see this not starting.

4. Select "Manage Services" from right-click menu
5. Note - no running mysqld service listed (it is running).
[17 Nov 2012 3:40] Miguel Solorzano
notifier

Attachment: notifier.png (image/png, text), 20.27 KiB.

[17 Nov 2012 3:42] Miguel Solorzano
Thank you for the bug report. I was only able to repeat the item 1:

1. fails to run on windows startup (after option is selected);

For item 2 please see attached picture. Thanks.
[3 May 2013 20:29] Random User
Msconfig startup items

Attachment: Capture.PNG (image/png, text), 23.95 KiB.

[3 May 2013 20:31] Random User
Accidently added file seperatly, anyway:

Still hasn't been fixed.

Cause might be as image provided above that the startup link is of "file:///..." instead of "c:\..."

A work around would be to use task scheduler to create a new task to run on log on and execute the .exe, thats how I did it and it works.

Explanation on how to add a task with task scheduler:

http://www.sevenforums.com/tutorials/67503-task-create-run-program-startup-log.html

Path to mysql notifier: "C:\Program Files (x86)\MySQL\MySQL Notifier 1.0.3\MySQLNotifier.exe"
[20 May 2013 19:48] Javier Rivera Zavala
Issue #1. fails to run on windows startup (after option is selected); is a duplicate of 16832752.
[24 May 2013 5:27] Philip Olson
This is fixed as of the upcoming MySQL Notifier 1.1.2 release, and here's the changelog entry:

  Sometimes the MySQL Notifier would fail to automatically add
  MySQL services to the monitor even when the
  AutoAddServicesToMonitor option was enabled.

Thank you for the bug report.