Bug #67586 SplitterDistance value of -132
Submitted: 14 Nov 2012 12:51 Modified: 16 Nov 2012 15:03
Reporter: Eduardo Queiroz Eduardo Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.44 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition (build 7600), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[14 Nov 2012 12:51] Eduardo Queiroz Eduardo
Description:
Parameter name: SplitterDistance

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.44  revision 9933
Configuration Directory: C:\Users\IXMED_TI\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition (build 7600), 32-bit
CPU: 4x AMD Phenom(tm) II X4 850 Processor, 3.3 GiB RAM
Active video adapter (0): NVIDIA GeForce 7025 / NVIDIA nForce 630a (Microsoft Corporation - WDDM)
Installed video RAM: 256 MB
Current video mode: 1024 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.11.8593
Installed display drivers: nvd3dum.dll,nvwgf2um.dll
Current user language: Português (Brasil)

Exception = System.ArgumentOutOfRangeException
Message = Value of '-132' is not valid for 'SplitterDistance'. 'SplitterDistance' must be greater than 0.
Parameter name: SplitterDistance
FullText = System.ArgumentOutOfRangeException: Value of '-132' is not valid for 'SplitterDistance'. 'SplitterDistance' must be greater than 0.
Parameter name: SplitterDistance
   at System.Windows.Forms.SplitContainer.set_SplitterDistance(Int32 value)
   at MySQL.GUI.Workbench.SqlIdeForm.LoadFormState()
   at MySQL.GUI.Workbench.SqlIdeForm.DbSqlEditor_Shown(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnShown(EventArgs e)
   at System.Windows.Forms.Form.CallShownEvent()
   at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
   at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
   at System.Windows.Forms.Control.InvokeMarshaledCallbacks()

How to repeat:
Parameter name: SplitterDistance
[16 Nov 2012 15:03] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=65961 .