Bug #67521 Instant error message on first run.
Submitted: 8 Nov 2012 15:17 Modified: 8 Nov 2012 17:42
Reporter: Rasmus Schultz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.44 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[8 Nov 2012 15:17] Rasmus Schultz
Description:
Just installed, ran for the first time, clicked one button: "New EER Model" on the welcome page - boom, error.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.44  revision 9933
Configuration Directory: C:\Users\mindplay.dk\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
CPU: 2x Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz, 4.0 GiB RAM
Active video adapter (0): Mobile Intel(R) 965 Express Chipset Family
Installed video RAM: 384 MB
Current video mode: 1920 x 1200 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.1930
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Active video adapter (1): Mobile Intel(R) 965 Express Chipset Family
Installed video RAM: 0 MB
Current video mode: 1280 x 800 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.1930
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Current user language: English (United States)

Exception = System.InvalidOperationException
Message = The Undo operation encountered a context that is different from what was applied in the corresponding Set operation. The possible cause is that a context was Set on the thread and not reverted(undone).
FullText = System.InvalidOperationException: The Undo operation encountered a context that is different from what was applied in the corresponding Set operation. The possible cause is that a context was Set on the thread and not reverted(undone).
   at System.Threading.SynchronizationContextSwitcher.Undo()
   at System.Threading.ExecutionContextSwitcher.Undo()
   at System.Threading.ExecutionContext.runFinallyCode(Object userData, Boolean exceptionThrown)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteBackoutCodeHelper(Object backoutCode, Object userData, Boolean exceptionThrown)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
   at System.Windows.Forms.Control.InvokeMarshaledCallbacks()

How to repeat:
Install, click "New EER Model"
[8 Nov 2012 17:42] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=67117 .