Bug #67415 Newest version odbc 5.2,2 fails to WRITE from Access forms to MySQL database
Submitted: 29 Oct 2012 23:26 Modified: 2 Nov 2012 8:32
Reporter: Jonathan Ornstein Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.2(w) OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[29 Oct 2012 23:26] Jonathan Ornstein
Description:
Hello.
I have been using MySql connectors ODBC with an Access 2007 (front-end) database on Windows 7 for many months/years without any problem, using a MySQL backend hosted by provider (version?).
Latest version that works without problems:
mysql-connector-odbc-5.1.10-win32 

Then, I installed mysql-connector-odbc-5.2.2-win32.The information in the back-end is displayed without a problem, but attempting to save data (any data) yields an error message:
ODBC -- update on a linked table 'table_name' failed.
[MySQL][ODBC 5.2(w) Driver][mysqld-5.0.45]Server does not support 4-byte encoded UTF8 characters. (#0)
Best regards,

Jonathan

How to repeat:

* install driver on windows XP/ 7 (tried 32 and 64 versions) pc
* create simple Access database with form that reads/writes to linked MySQL table
* make sure to have a Save function to write data to database
* open form, enter or alter some data in 1 of the fields
* try to save data

Suggested fix:
 sorry, no idea at all
[30 Oct 2012 15:26] Miguel Solorzano
Thank you for the bug report. I can't repeat with Access (2007 - 2010) against a MySQL Server 5.5 and table including an INT auto_increment and timestamp columns. Please describe your environment plus the create table statement. Thanks.
[31 Oct 2012 12:15] Miguel Solorzano
Duplicate of http://bugs.mysql.com/bug.php?id=67428 (already verified).
[2 Nov 2012 8:32] Jonathan Ornstein
My provider, it turns out, is still running MySQL 5.0 on their servers, having delayed the previously announced upgrade to 5.5. Is this the embarassing answer to the problem? So not really a bug at all but a compatibility issue? What does then surprise me is that the OBDC connector can READ the data from the older version of MySQLwithout any problem, but cannot WRITe to an older version of MySQL.

Best regards
Jon