Bug #67405 exception while editing column name
Submitted: 28 Oct 2012 22:48 Modified: 10 Dec 2012 20:08
Reporter: Bogdan Fürst Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.44 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition (build 7600), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[28 Oct 2012 22:48] Bogdan Fürst
Description:
exception while editing second column name of newly added table (default type INT)

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.44  revision 9933
Configuration Directory: C:\Users\AI\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition (build 7600), 64-bit
CPU: 8x Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 6.0 GiB RAM
Active video adapter (0): ATI Radeon HD 5800 Series
Installed video RAM: 1024 MB
Current video mode: 1920 x 1200 x 4294967296 colors
Used bit depth: 32
Driver version: 9.2.0.0
Installed display drivers: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Slovenian (Slovenia)

Exception = System.NullReferenceException
Message = Object reference not set to an instance of an object.
FullText = System.NullReferenceException: Object reference not set to an instance of an object.
   at MySQL.Utilities.AdvNodeTextBox.textBox_TextChanged(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnTextChanged(EventArgs e)
   at System.Windows.Forms.TextBoxBase.OnTextChanged(EventArgs e)
   at System.Windows.Forms.TextBoxBase.WmReflectCommand(Message& m)
   at System.Windows.Forms.TextBoxBase.WndProc(Message& m)
   at System.Windows.Forms.TextBox.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
add new table;
add column Id of type tyinint, check UN, AI;
start editing name for next column, type "Code";
press <Home>;
press <Delete> -> exception
[29 Oct 2012 14:30] Bogdan Fürst
exception is handled and does not cause a crash; work may continue without loss.
[29 Oct 2012 18:07] Rafael Antonio Bedoy Torres
Hello Bogdan,
I can't reproduce your bug, are you able to get the exception again?
[31 Oct 2012 13:28] Bogdan Fürst
No. But since visualy everything looked ok, I'd bet EditorTextBox was null, because Parent seem never to be explicitly set to null...

private void textBox_TextChanged(object sender, EventArgs e)
{
  _label = EditorTextBox.Text;
  Parent.UpdateEditorBounds();
}

internal void HideEditor(Control editor)
{
...
   _editor = null;
...
}
[10 Dec 2012 20:08] Ruben Dario Morquecho Valdez
Thank you for your bug report. 
This issue has ben not reproduced again

thanks for interesting in Workbench