Bug #67383 wb crash sometimes when opening sql editor on big instance
Submitted: 26 Oct 2012 6:33 Modified: 15 Jan 2013 15:48
Reporter: Marcin Szalowicz Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.44 OS:Linux (ubuntu 12.04/amd64)
Assigned to: CPU Architecture:Any
Tags: big instance, crash, sql editor

[26 Oct 2012 6:33] Marcin Szalowicz
Description:
Sometimes when opening big instance (above hundred of schemas) wb will crash.
In attached file there is stack trace

How to repeat:
create connection to big instance (above hundred of schemas)
open sql editor 
...crash...
[26 Oct 2012 6:35] Marcin Szalowicz
Crash stacktrace

Attachment: wbcrashstack.log (application/octet-stream, text), 32.55 KiB.

[26 Oct 2012 18:31] Rafael Antonio Bedoy Torres
Hello,

May you please tell us how many schemas you are trying to manage?, we need a more detailed report in order to reproduce and fix.

Thanks in advance!
[29 Oct 2012 9:30] Marcin Szalowicz
the smallest instance got about 100, the biggest one 700
[28 Dec 2012 20:20] Miguel Solorzano
Please try version 5.2.45. Thanks.
[2 Jan 2013 12:57] Marcin Szalowicz
well i see it's better using for few days and sql editor now open much more faster, i also can't reproduce this bug so i think it can be marked as fixed :)
[15 Jan 2013 15:48] Ruben Dario Morquecho Valdez
Thank you for your bug report. 
This issue cannot be reproduce anymore in latest released version.

Thanks for interest in mySQL Workbench!