Bug #6735 "prompt=" option in my.cnf causes problems with command-line client tools
Submitted: 21 Nov 2004 2:09 Modified: 21 Nov 2004 4:32
Reporter: Michael Kruckenberg Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:4.0.20 OS:Solaris (Solaris 8)
Assigned to: CPU Architecture:Any

[21 Nov 2004 2:09] Michael Kruckenberg
Description:
If the prompt option is set in my.cnf the command-line tools mysqladmin, mysqlbinlog, mysqldump, mysqlcheck and mysqlshow display this error:

mysqldump: ERROR: unknown variable 'prompt=mysql-prod>'

These tools need to be made aware of this option so the --no-defaults doesn't have to be used which causes the rest of the my.cnf file to be ignored.

How to repeat:
Put "prompt = production>" in the global or local my.cnf and try to run the command-line tools. You can only get them to run by using the --no-defaults which then ignores everything else that is set up in the my.cnf file.

Suggested fix:
Add prompt option awareness to these tools so they can operate without having to use --no-defaults.
[21 Nov 2004 3:54] Paul Dubois
It sounds as though you might have this option
in the [client] group, which is intended for options
understood by all client programs.  If so, try
putting it in the [mysql] group instead, which
applies only to the mysql program.
[21 Nov 2004 4:01] Michael Kruckenberg
Ah, it works as it should in the [mysql] section. Sorry for the trouble.
[21 Nov 2004 4:32] Paul Dubois
Okay, good.  Thanks for reporting back.

By the way, I forgot to give this reference
in my earlier response:

http://dev.mysql.com/doc/mysql/en/Option_files.html