Bug #67252 Very slow fetching of even small query results with MySQL 5.6.7
Submitted: 16 Oct 2012 7:16 Modified: 17 Oct 2013 6:07
Reporter: Olag Ulga Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.43 5.2.44, 5.2.45, 5.2.47 OS:Microsoft Windows (Win8x64 Win7x64)
Assigned to: CPU Architecture:Any
Tags: slow fetching result
Triage: Needs Triage: D2 (Serious)

[16 Oct 2012 7:16] Olag Ulga
Description:
Fetching of a query result in SQL Editor is very slow with MySQL 5.6.7-rc-log, Win64. With other sql tools the problem does not occure.

How to repeat:
- Start Workbench and open the sql editor with a connection to MySQL 5.6.7-rc-log
- Open new query tab (CTRL + T)
- Execute:
CREATE SCHEMA `slow`;
Use `slow`;
CREATE  TABLE `tblSlow` (
  `Id` INT NOT NULL AUTO_INCREMENT ,
  PRIMARY KEY (`Id`) )
ENGINE = InnoDB;
- Refresh the object browser that it displays the slow schema
- go to the tblslow and click 'Select Rows - Limit 1000' in the context menu
- now it takes several seconds to fetch the empty result despite the execution duration from the output panel displays 0.000 seconds

Suggested fix:
the result should be displayed instantly
[16 Oct 2012 11:44] Miguel Solorzano
Thank you for the bug report. I can't to repeat on 2 different machines running Windows 7 64-bit (Ultimate/Professional). Your connection is local or remote? Against which MySQL server version are you queyring?. Thanks.
[16 Oct 2012 15:36] Olag Ulga
The Server is MySQL 5.6.7-rc-log, Win64 running on Win 7 x64 / Enterprise.

The problem is reproducible if Workbench is running on the same machine over TCP/IP to localhost or from another machine in the LAN over TCP/IP running on Win 8 x64 / Enterprise.

I tested some more things and it seems that it is fast with one database and becomes slow with more databases (tested with 71 databases). The original problem server has 427 databases. With MySQL 5.5 and 5.1 this is no problem.
[16 Oct 2012 16:07] Miguel Solorzano
Thank you for the feedback. Then the main point to be repeatable is to have around 71 databases in the server?. Thanks.
[18 Oct 2012 7:50] Olag Ulga
Yes the problem occures if you have a lot of databases.
[28 Nov 2012 15:43] Olag Ulga
Could you please verify this bug. It is annoying!

Thanks
[28 Dec 2012 20:51] Miguel Solorzano
Thank you for the feedback.
[12 Mar 2013 9:34] Olag Ulga
Still not fixed in 5.2.47
[2 Apr 2013 23:12] Marco Callegari
It's the same on 5.2.47 for OSX (mountain Lion).
With 10 database with about 100 tables each one, I got about 6 or 7 seconds for getting tables content. After deleting 8, now it's just 1 or 2 seconds...
[2 Apr 2013 23:14] Marco Callegari
I forgot. I'm using mysql 5.6, and I'm on a mac pro 6-core with 12GB RAM.
MySQL is fast with PHP or using SequelPro.
It's slow just with Workbench.
All my databases are local.
[26 Jun 2013 16:44] Alfredo Kojima
Duplicate of bug #55364
[1 Jul 2013 5:28] sdfasd sdf
same issue for me. fetching 1 row in one table, and one database. Yet it takes ~30sec to fetch the data. Duration log shows 0.050 sec for duration and 0.000 sec for fetching.
[14 Jul 2013 7:53] Olag Ulga
The Bug #55364 describes a completely different behaviour. It describes a performance problem, if selecting large amount of data. This bug describes a performance problem, if selecting very few data. 

changelog entry of #55364: "MySQL Workbench suffered from slow performance when selecting a large amount of data, such as 100,000+ rows."

I don't think that this bug is a dupplicate of #55364.

@Alfredo Kengi Kojima: Why should this be a dupplicate???

I will try to reproduce with MySQL Workbench 6.0.3 in 3 weeks.
[17 Oct 2013 6:07] Olag Ulga
Fixed in 6.0.7