Bug #67118 MySQL 5.6.7 fails on add the firewall rule.
Submitted: 7 Oct 2012 8:44 Modified: 8 Oct 2012 1:17
Reporter: MELERIX ... Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.6.7 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any
Tags: firewall

[7 Oct 2012 8:44] MELERIX ...
Description:
during the install of MySQL 5.6.7, installer fails on add the firewall rule, so MySQL service is not configured properly, then you can't connect to MySQL server after install finished.

now if you see inside windows firewall rules (when mysql install has finished), there is a firewall rule (MySQL56) present in the list.

but sadly, now there is no way to re-configure mysql server instance!

how we can re-configure mysql server if it fails during install ?

where is now the "Server Instance Configuration Wizard" for MySQL 5.6.x ?

this is the log from mysql installer:
mysql-server-5.6-win32:6 - Looking for valid template
mysql-server-5.6-win32:12 - Found valid template.
mysql-server-5.6-win32:18 - Attempting to process template.
mysql-server-5.6-win32:25 - Processed template.
mysql-server-5.6-win32:31 - Attempting to configure service.
mysql-server-5.6-win32:37 - Configured service.
mysql-server-5.6-win32:43 - Attempting to start service.
mysql-server-5.6-win32:50 - Started service.
mysql-server-5.6-win32:56 - Adding firewall rule for MySQL56 on port 3306.
mysql-server-5.6-win32:62 - Adding firewall rule failed.
mysql-server-5.6-win32:68 - Attempting to update security settings.
mysql-server-5.6-win32:75 - Updated security settings.
mysql-server-5.6-win32:81 - Attempting to verify command-line client shortcut.
mysql-server-5.6-win32:100 - Failed to verify command-line client shortcut.
mysql-server-5.6-win32:100 - Product configuration controller finished configuration.

How to repeat:
1 - Download MySQL installer for MySQL 5.6.7
2 - Install MySQL Server only, and follow steps normally.
3 - it fails on add the firewall rule.
[8 Oct 2012 1:17] MySQL Verification Team
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=62685