Bug #67111 Synchronize with any datasource
Submitted: 6 Oct 2012 13:22 Modified: 27 Sep 2013 5:10
Reporter: Christian Jacobs Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.44 OS:Microsoft Windows (Microsoft Windows XP Professional Service Pack 3 (build 2600))
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[6 Oct 2012 13:22] Christian Jacobs
Description:
When I go to synchronize with any datasource and I have to define the source & destination database, I select one of the stored connections.

Issue: It seems to save the previous selected stored connection for source and destination in one variable and not in two.
e.g. when I change the destination and complete the task, and start this process again, the pre-selected source connection has changed and is the same as the previously selected destination connection.

How to repeat:
Define source(stored connection) and destination(stored connection) for the synchronize with any datasource process. Complete the task.
Start the process again - select another destination(stored connection). Complete the task.
Start the process again => source database(stored connection) has changed.
[8 Oct 2012 1:20] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67113 marked as duplicate of this one.
[8 Oct 2012 11:47] Christian Jacobs
Hi Miguel,

I appreciate your quick response but ticket #67111 and #67113 are not the same.

Regarding #67111: I attached some screenshots to visualize it.
Eample:
First run: I use the pre-selected suggested connection for source (db01).
I change the connection for destination (db02).
Second run: The pre-selected suggested connection has changed to db02 but I haven't changed it.
=> It saves the last change but source and destination not independent.

Regarding #67113: Synchronize with any source doesn't execute the synchronization.
When I select one table pair to synchronize, it shows me the sql statement below.
When I'm going to the next screen it shows me just the following standard lines but not the sql statements.

SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0;
SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0;
SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='TRADITIONAL';

<<MISSING SQL STATEMENTS>>>

SET SQL_MODE=@OLD_SQL_MODE;
SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS;
SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS;

When I click on execute, it doesn't execute the synchronization.
You can proof it when you run the process again and the tables are not synchronized.
[25 Oct 2012 15:20] Armando Lopez Valencia
Thanks for your report.
Verified in:
Windows 7x64
WB 5.2.44 rev 9933
What the reporter suggest is that the source connection should be pre-populated with the latest SOURCE connection used, instead of the last connection used (DESTINATION connection).
[27 Sep 2013 5:10] Philip Olson
Fixed as of MySQL Workbench 6.0.4, and here's the changelog entry:

After synchronizing with a data source by defining the source and
destination databases, the previously selected stored connections would
sometimes be incorrect.

Thank you for the bug report.