Bug #67053 config wizard ships with template using deprecated option
Submitted: 2 Oct 2012 11:50 Modified: 17 Aug 2017 21:44
Reporter: Peter Laursen (Basic Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:5.1, 5.5 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D4 (Minor)

[2 Oct 2012 11:50] Peter Laursen
Description:

reads:

"
..
# The number of open tables for all threads. Increasing this value
# increases the number of file descriptors that mysqld requires.
# Therefore you have to make sure to set the amount of open files
# allowed to at least 4096 in the variable "open-files-limit" in
# section [mysqld_safe]
table_cache=<<{:RM=256,[max_connections]*2}>>
##
_buffers_memory=<<<{:=[_buffers_memory]-[table_cache]*8K}>>>
..
"

MySQL 5.1 docs: http://dev.mysql.com/doc/refman/5.1/en/server-system-variables.html clearly tells that since 5.1.3 table_cache is deprecated and replaced with table_open_cache.  In 5.6.7 table_cache is removed and not recognized.

I came across this as I tried to configure 5.6.7 with the wizard and template ('my-template.ini') shipping with 5.5.28 'standalone installer'. I had to edit 'table_cache' to 'table_open_cache' in the generated my.ini in order to start the server successfully.

(not sure if it is fixed with the wizard as included with 5.6 'unified installer' as I was not able to run it - refer my blog: http://www.webyog.com/blog/2012/08/19/mysql-windows-installer-mess/)

How to repeat:
see above

Suggested fix:
Ship all templates (whether bundled with the server, the config wizard or whatever) with up-to-date - and not deprecated or removed - options.
[2 Oct 2012 12:00] Miguel Solorzano
Thank you for the bug report.
[16 Mar 2016 1:53] Javier Treviño
Posted by developer:
 
Changing the product and category to the MySQL Installer for Windows, since the template shipped with the Installer is the one that needs updating.
I confirmed that for 5.1 and 5.5, this variable is still used in the my.ini file created by the MySQL Installer for Windows.
It needs to either replace the table_cache with table_open_cache, or not include it at all. Better to double-check with the Server team if it is safe just to replace it before doing so.

The deprecated value is not interfering with the functionality of the server, but the table cache is not being taken advantage of.
[12 Aug 2017 3:46] Javier Treviño
Posted by developer:
 
Replaced the no longer available table_cache variable with table_open_cache in all Server 5.1 and 5.5 configuration files; just in the same way the variable was already replaced for Server 5.6 and greater.
[16 Aug 2017 20:52] Rafael Antonio Bedoy Torres
Posted by developer:
 
Fixed on 1.4.20 build 2
[17 Aug 2017 21:44] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Installer 1.4.20 release, and here's the changelog entry:

MySQL 5.1 and MySQL 5.5 server configuration templates continued to
included the table_cache server system variable, which is no longer valid.
This fix replaces table_cache with the table_open_cache variable in the
configuration files of these servers.

Thank you for the bug report.