Bug #66995 Huge model not work
Submitted: 27 Sep 2012 19:25 Modified: 14 Dec 2016 16:43
Reporter: Thomas Lee Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:Mysql 5.5 OS:Microsoft Windows (W2003 Server 64 Bit)
Assigned to: CPU Architecture:Any
Tags: Turn into huge model
Triage: Needs Triage: D1 (Critical)

[27 Sep 2012 19:25] Thomas Lee
Description:
I copy the my-huge.in file make it as my.ini then I try to edit table data from WorkBench, but the data base is gone, only see system database available

How to repeat:
copy / paste the ini file
[27 Sep 2012 20:03] Peter Laursen
This is really an odd issue with MySQL (from 5.5) IMO!

The ini-'templates' do not have a /datadir setting.  If you have installed with an automatic installer the /datadir used is not a subfolder to the /basedir (installation folder).  To resolve this just copy the /datadir specification (a single line) from the .ini generated by the installer to the [mysqld] section of the 'template' you use.

From MySQL 5.5 the automated installer will create a /data folder as subfolder to /basedir (in addition to the one specified with /datadir). BUT IT IS NOT USED! So when you start the server with no /datadir -setting pointing to the data you have already been working with the data accessed by the server is like after a fresh install.

Before 5.5 the installer would not write this unused data folder and the server would refuse to start (what I think is more correct). I think I posted an old bug report myself, but cannot find it now.

if installed wiht the automated isntaller the used data folder is C:\ProgramData\MySQL\MySQL Server 5.5\data and the the unused data folder is: C:\Program Files\MySQL\MySQL Server 5.5\data.

Can you understand me?

Peter
(not a MySQL/Oracle person)
[27 Sep 2012 20:16] Miguel Solorzano
Thank you for the bug report.
[28 Sep 2012 13:04] Thomas Lee
I dont see \ProgramData\ folder but \Mysql 5.5\Data which not shown used database either. The copy / paste may be missing some hidden data. I try 
to rename my-huge.in as my.ini directly by renaming old one to other. Re-start
PC, still cant edit used db
[28 Sep 2012 13:23] Peter Laursen
You will need to add a /datadir specification to what .ini you use. You will find that in the old .ini that worked (if you have not deleted it). It is a single line starting with the word "datadir" followed by a file path. This line will need to be inserted into the [mysqld] section of the new .ini (the one renamed from the my_huge.ini). You will then use the same /datadir as before when server restarts.

Just open the two .ini's in a plain text editor (Notepad or whatever) and see.

Besides .. you are now asking for support, I think.  The bugs system is not a place for support.  Not that I care, but Miguel probably does. (Free) support for MySQL is available from here: http://forums.mysql.com/ .  I have no obligation to help users if they are not our customers - even though I did many times before this. 

Now let Miguel comment, too. I was actually surprised to see Miguel verifying this bug and even assigning "D1" (highest criticality) to it. He may have seen something that I have not. I discussed this with some person here when a very early 5.5 was released and I noticed this unused /datadir for the first time, and was told that this was 'not a bug'. Maybe the configuration wizard needs the server to run and starts it with the /datadir in subfolder to /basedir and restarts the server after configuration is complete (but I think then the temporary /datadir should be deleted when it is not used anymore!)
[28 Sep 2012 13:51] Peter Laursen
One more hint: \ProgramData is a *hidden* folder. To unhide it go to Control Panel .. Folder options.

Now you are using Windows2003 server.  I think the folder here should be found in \Application Data\All Users (I did not use XP/2003 for almost 5 years so I don't remember full details). But it is still hidden unless you configured Windows to show hidden folders/system folder from Control Panel .. Folder Options.
[28 Sep 2012 13:56] Peter Laursen
Besides I would disadvice to trust the 'templates'.  They have not been updated for almost 10 years.  The my-huge.ini maybe was *huge* at the time when server systems rarely had more than 1 GB ram (and desktops systems had 128MB or 256MB typically).

Learn to build your own configuration or use a good 'configurator' software (there a several ones online) or use a monotoring tool with build-in 'advisors'.
[14 Dec 2016 16:43] Paul Dubois
For 5.6 and up, these files are no longer shpped.

http://dev.mysql.com/doc/refman/5.6/en/server-default-configuration-file.html

The my-default.cnf template replaces the older sample option files formerly supplied with MySQL distributions (my-small.cnf, my-medium.cnf, my-large.cnf, and my-huge.cnf). As of MySQL 5.6.8, these older files are no longer distributed.

For 5.5, best to add a datadir specification to any template file used, as necessary.