Bug #66961 ndb.nextEvent crashes when called from Java API
Submitted: 25 Sep 2012 21:53 Modified: 22 Jul 2013 20:48
Reporter: Jim Fontana Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Cluster: Cluster/J Severity:S3 (Non-critical)
Version:mysql-cluster-gpl-7.2.8 OS:Microsoft Windows (Windows 7)
Assigned to: CPU Architecture:Any

[25 Sep 2012 21:53] Jim Fontana
Description:
Converted NDB API Event Handling examples to Java using ClusterJ API. The nextEvent call crashes consistently. 

How to repeat:
Can repeat consistently by starting the cluster, starting the event handling Java program and letting it go its wait loop and then inserting or deleting a row from the sample database.
[25 Sep 2012 21:54] Jim Fontana
Crash dump file

Attachment: hs_err_pid4664.log (application/octet-stream, text), 7.86 KiB.

[25 Sep 2012 21:55] Jim Fontana
Java program

Attachment: Atomizer.java (application/octet-stream, text), 4.75 KiB.

[25 Sep 2012 22:18] Jim Fontana
False report. prevRecAttr array needs to be initialized. Please remove this bug.
[22 Jul 2013 20:48] Sveta Smirnova
Thank you for the feedback.

Closed as "Not a bug".