Bug #66886 Published documentation for MySQL 5.0 mysql.proc is incorrect
Submitted: 20 Sep 2012 6:06 Modified: 22 Apr 2013 18:13
Reporter: Michael McLaughlin Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.0.91 OS:Any
Assigned to: Paul Dubois
Tags: mysql.proc
Triage: Needs Triage: D5 (Feature request)

[20 Sep 2012 6:06] Michael McLaughlin
Description:
The table mysql.proc definition does not match with the MySQL 5.0 release

http://dev.mysql.com/doc/refman/5.0/en/routines-table.html

The issue is qualified in:

http://bugs.mysql.com/bug.php?id=66861

The correct definition is noted in a comment at my blog:

http://blog.mclaughlinsoftware.com/2012/09/13/trying-to-migrating-data/#comment-443273

How to repeat:
Download MySQL 5.0.91 and verify the definition in the data catalog.

Suggested fix:
Update the page to reflect the actual definition of the mysql.proc table.
[20 Sep 2012 9:54] Valerii Kravchuk
Sorry, but why do you think that mysql.proc table should be documented at the manual page devoted to INFORMATION_SCHEMA.ROUTINES table?
[20 Sep 2012 17:27] Michael McLaughlin
My bad, it was the only page that I could find that referenced the mysql.proc table. The lack of a page for the mysql.proc table leads to problems for those migrating from older versions. However, I found the disclaimer on MySQL 5.0 and understand if you don't want to address this:

http://dev.mysql.com/doc/refman/5.0/en/index.html

It seems that providing a list of the mysql, information_schema, and performance_schema database tables for all releases would be constructive in eliminating questions and supporting users. Especially those tasked with upgrading older releases, which have fallen behind.

On reflection, perhaps this should be a documentation feature request.
[20 Sep 2012 20:16] Sveta Smirnova
Thank you for the report.

> It seems that providing a list of the mysql, information_schema, and performance_schema database tables for all releases would be constructive in eliminating questions and supporting users. Especially those tasked with upgrading older releases, which have fallen behind.
>
> On reflection, perhaps this should be a documentation feature request.

Well, I can verify it as feature request. But since I am agree regarding to Information Schema and Performance Schema (and actually everybody agrees since we provide such documentation for their tables), mysql schema is different, because it is schema used for internal server purposes and should never be used for write by database users in normal operations.

But lets let Docs Team do decide.
[21 Sep 2012 3:40] Michael McLaughlin
I'm not clear on whether they're provided for the information_schema or performance_schema because while this resolves to the information_schema.routines table:

http://dev.mysql.com/doc/refman/5.0/en/routines-table.html

What should be the parent page is empty?

http://dev.mysql.com/doc/refman/5.5/en/information-schema.html

I can't seem to find them, let me know if it's in a different chapter or something?
[22 Apr 2013 18:13] Paul Dubois
"I found the disclaimer on MySQL 5.0 and understand if you don't want to address this"

Right. Closing without action.

"What should be the parent page is empty?"

It might look empty, but scroll down.