Bug #66775 Invoke or BeginInvoke cannot be called on control unit until the window handle h
Submitted: 11 Sep 2012 19:26 Modified: 11 Sep 2012 19:44
Reporter: Peter K Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.42 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[11 Sep 2012 19:26] Peter K
Description:
Trying to startup workbench CE 5.2.42 from a desktop shortcut

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\PK\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.42
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 2x Intel(R) Core(TM)2 Duo CPU     T6670  @ 2.20GHz, 3.0 GiB RAM
Active video adapter (0): Mobile Intel(R) 4 Series Express Chipset Family
Installed video RAM: 0 MB
Current video mode: 1440 x 900 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.2302
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Active video adapter (1): Mobile Intel(R) 4 Series Express Chipset Family
Installed video RAM: 1292 MB
Current video mode: 1920 x 1080 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.2302
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Current user language: English (United States)

Exception = System.InvalidOperationException
Message = Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
FullText = System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   at MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
1. Created the shortcut/ 2. clicked on it/ 3. BOOOOMMMM !!!!!
[11 Sep 2012 19:44] Miguel Solorzano
Duplicate of bug http://bugs.mysql.com/bug.php?id=66758.