Bug #66739 Cannot seem to create database, nor to make a local connection.
Submitted: 8 Sep 2012 0:43 Modified: 11 Sep 2012 13:07
Reporter: Joshua Malnight Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.42 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[8 Sep 2012 0:43] Joshua Malnight
Description:
There are two bugs. When I try to create a new local connection, I am unable (using default settings). I am using Windows 7. 
Possibly because of this, when I attempt to forward-engineer the database, I cannot get past the options screen. 

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\Josh\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
CPU: 2x Pentium(R) Dual-Core CPU       T4400  @ 2.20GHz, 4.0 GiB RAM
Active video adapter (0): Mobile Intel(R) 4 Series Express Chipset Family
Installed video RAM: 1806 MB
Current video mode: 1366 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.2302
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Current user language: English (United States)

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
   at boost.function0<void>.()(function0<void>* )
   at boost.signals2.detail.slot_call_iterator_t<boost::signals2::detail::signal0_impl<void,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(void)>,boost::function<void __cdecl(boost::signals2::connection const &)>,boost::signals2::mutex>::slot_invoker,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> >,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> > > > >,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> 968d42b1(slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >* )
   at boost.signals2.optional_last_value<void>.operator()<class boost::signals2::detail::slot_call_iterator_t<class boost::signals2::detail::signal0_impl<void,class boost::signals2::optional_last_value<void>,int,struct std::less<int>,class boost::function<void __cdecl(void)>,class boost::function<void __cdecl(class boost::signals2::connection const &)>,class boost::signals2::mutex>::slot_invoker,class std::_List_iterator<class std::_List_val<class boost::shared_ptr<class boost::signals2::detail::connection_body<struct std::pair<enum boost::signals2::detail::slot_meta_group,class boost::optional<int> >,class boost::signals2::slot0<void,class boost::function<void __cdecl(void)> >,class boost::signals2::mutex> >,class std::allocator<class boost::shared_ptr<class boost::signals2::detail::connection_body<struct std::pair<enum boost::signals2::detail::slot_meta_group,class boost::optional<int> >,class boost::signals2::slot0<void,class boost::function<void __cdecl(void)> >,class boost::signals2::mutex> > > > >,clcc3763b0(optional_last_value<void>* , slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > first, slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > last)
   at boost.signals2.detail.signal0_impl<void,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(void)>,boost::function<void __cdecl(boost::signals2::connection const &)>,boost::signals2::mutex>.()(signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>* )
   at MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Create a database following the tutorial. Attempt to create a connection using the username 'root' and no password, which you store in a vault. Then try to forward-engineer it.
[11 Sep 2012 13:07] Miguel Solorzano
Thank you for the bug report. Duplicate of bug http://bugs.mysql.com/bug.php?id=66222 which presents same call stack.