Bug #6672 Configuration Wizard should provide debug info when server fails to start
Submitted: 16 Nov 2004 23:26 Modified: 28 Aug 2006 16:32
Reporter: Tom Metro Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:4.1.7 OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any
Triage: D4 (Minor)

[16 Nov 2004 23:26] Tom Metro
Description:
The MySQL Server Instance Configuration Wizard on Windows currently displays a small red "X" next to the "Service started" item when the service fails to start, but it provides no assistance or debugging information.

One of the disadvantages of using a Wizard is that it encourages users who aren't familiar with the manual installation and debugging procedures to perform an installation. Therefore when it fails to work, those users are especially stranded.

Another disadvantage of using a Wizard is that it hides details from users who do know how to troubleshoot problems. If the installation fails, they're faced with the problem of finding the log files, finding the configuration file that was used, and finding the exact command line options the Wizard used when installing the service.

How to repeat:
Run Configuration Wizard.
Specify parameters that will lead to a failed service (see other bug reports for options.)
Click the "Execute" button.
Observe the red "X" and that the only option is to click "<Back" and try again.

Suggested fix:
At minimum, a troubleshooting wizard should be shown to the user, which could be as simple as showing a text file giving troubleshooting steps, such as how to find the log files, how to start the server manually with --console, etc.

An improvement over that would be to also show the user the installation specific information, such as: log file location, configuration file location, and the exact command line options the Wizard used when installing the service.

Ideally, the Wizard, in addition to providing troubleshooting information, should perform some diagnostics itself, such as locating the log file and displaying its contents, if the service got as far as writing to the log. If it didn't, it should run the server directly with --console, capture the output, and show it to the user.
[8 Jul 2005 10:47] Michel Polotto
Precisely. Am trying to install mysql-4.1.12a-win32 (single Setup.exe of 38MB) on Win XP SP2, brand new PC, and it fails starting the service. No explanation (error 0), no hints, no nothing.

BTW 4.0.24 does not start either,. Completely in the dark. I'm mot impressed, though using 3.xx (21?) for a couple of years without too much probs.

20 years in software Windows, Unix, Linux, OpenVMS, C, C++, PHP, Perl, ... 4GL tools, and after 2 days trying, still no progress. Non-brwosable buglist (by category, e.g. installing) makes it harder to find clues.

Is Mysql / TCX truing in to Microsoft/IBM like supplier?

Michel Polotto
The Netherlands
[8 Jul 2005 10:50] Michel Polotto
As an afterthought, looks like your speaking into a bottomless pit here ... (Tom's submission dated 17 Nov 2004 and no replies ????

Is anybody there????

Michel Polotto
[9 Jul 2005 21:53] Tom Metro
> As an afterthought, looks like your speaking into a bottomless pit here ...

In their defense, I submitted about a half dozen bug reports around the same time as this one, and the ones with a severity higher than "feature request" did at least get investigated and commented on by MySQL people.

> Am trying to install mysql-4.1.12a-win32 ...and it fails starting the service. 
> No explanation (error 0), no hints, no nothing.

Have you tried the troubleshooting procedures that are documented (somewhere) in the manual, such as starting the server manually with --console option?
[5 Sep 2005 21:27] IZILLI
I've had exactly the same problem when installing MySQL 4.1.13a when i click on the execute button and the service (red cross on the left of Service step) fail.

The cause of this is that the localhost is already running and can't be available by MySql to create the Service.

The solution is as follow:
Go to Control Panel>Administrative Tool>Services
Find the "IIS Admin" service
Right click on it and select "Stop"
Right click again on it and select the "Properties" menu item, in the "General" tab select "Manual" or "Disabled" regarding the "Startup Type".

This, is optional, but to be sure here is what I did:
After that I've uninstall MySql (check no MySQL directories exist after that) and then I've deleted everything in the registry (be careful doing that).

Reboot the computer.
Check that "MySQL" service has desappear (see above). If not, the service is still in the registry (do a "Start program>Run and type "regedit" for deletion).

Re-install the MySQL package and all will work fine, the "service" will work and either the "apply security setting".

Hope this will help someone.
Tell me if you are still in trouble (or happy) by replying to me and i will do my best to help you.
[28 Aug 2006 1:29] Matt Franklin
What if this same problem occurs when running an Apache server?  Coincidentally I can only stop my Apache server through Ctrl Alt Del, there is no option to do so under Start-Programs-Apache Group, but that's an Apache problem.

The version of MySQL I'm trying to work with is the same as the one above, 4.1.21 on a Windows XP Pro edition.  I'm trying to work with PHP, and I've got the PHP environment pretty much working in Apache.  All I need is MySQL
[28 Aug 2006 16:28] Tom Metro
IZILLI wrote:
> ...when i click on the execute button and the service...fail.
> 
> The cause of this is that the localhost is already running and can't 
> be available by MySql to create the Service.
> 
> The solution is...Find the "IIS Admin" service...and select "Stop"

I don't follow the theory of why stopping the IIS service would permit MySQL to install. A service can fail to start if it tries to bind to a local port already in use by another service, but there are no conflicts between MySQL and a web server.

It seems more likely that this worked coincidentally.

Repeating my prior advice, I'd recommend following the troubleshooting procedures that are documented in the manual, such as starting the server manually with --console option. This will usually output some helpful error messages.

 -Tom
[28 Aug 2006 16:32] Tom Metro
Matt Franklin wrote:
> What if this same problem occurs when running an Apache server? 

I doubt it is related.

> ...I can only stop my Apache server through [the task manager]...

It's a service, so you'll find it in the Services applet. You can also control it from the command line using 'net start/stop'. On my system 'net stop apache2' stops the service.

 -Tom
[11 Mar 2008 16:55] mysql tutorial to
http://www.phpbits.info/