Bug #66698 Please rename validate_password_policy_number
Submitted: 4 Sep 2012 20:54 Modified: 28 Jan 2013 13:12
Reporter: Todd Farmer (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Security: Privileges Severity:S3 (Non-critical)
Version:5.6.6 OS:Any
Assigned to: CPU Architecture:Any

[4 Sep 2012 20:54] Todd Farmer
Description:
The new variable introduced with the password verification plugin, validate_password_policy_number, is named such that it suggests that it expects a numeric value.  While it can accept numeric values, the most common usage (and the way it is helpfully reported) uses English symbolic equivalents:

mysql> SET GLOBAL validate_password_policy_number = 1;
Query OK, 0 rows affected (0.00 sec)

mysql> SELECT @@global.validate_password_policy_number;
+------------------------------------------+
| @@global.validate_password_policy_number |
+------------------------------------------+
| MEDIUM                                   |
+------------------------------------------+
1 row in set (0.00 sec)

mysql> SET GLOBAL validate_password_policy_number = 0;
Query OK, 0 rows affected (0.00 sec)

mysql> SELECT @@global.validate_password_policy_number;
+------------------------------------------+
| @@global.validate_password_policy_number |
+------------------------------------------+
| LOW                                      |
+------------------------------------------+
1 row in set (0.00 sec)

How to repeat:
See above.

Suggested fix:
Change the variable name to something like, "validate_password_policy".
[28 Jan 2013 13:12] Erlend Dahl
Noted in 5.6.10, 5.7.1 changelogs:

The validate_password_policy_number system variable was renamed to validate_password_policy.