Bug #66648 Forward Engineer
Submitted: 2 Sep 2012 1:36 Modified: 30 Nov 2012 2:27
Reporter: Paulo Martins Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.42/5.2.43/5.2.44 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter
Triage: Needs Triage: D3 (Medium)

[2 Sep 2012 1:36] Paulo Martins
Description:
The application receives an exception from an external component when I try to forward engineer. I assume it is due to the absence of the server, but I just want to generate the script, and that used to work on previous versions.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\Paulo\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 8x Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz, 8.0 GiB RAM
Active video adapter (0): NVIDIA GeForce GTX 460M      
Installed video RAM: 1536 MB
Current video mode: 1920 x 1080 x 4294967296 colors
Used bit depth: 32
Driver version: 8.17.12.6114
Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Current user language: Portuguese (Portugal)

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
   at boost.function0<void>.()(function0<void>* )
   at boost.signals2.detail.slot_call_iterator_t<boost::signals2::detail::signal0_impl<void,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(void)>,boost::function<void __cdecl(boost::signals2::connection const &)>,boost::signals2::mutex>::slot_invoker,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> >,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> > > > >,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> 968d42b1(slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >* )
   at boost.signals2.optional_last_value<void>.operator()<class boost::signals2::detail::slot_call_iterator_t<class boost::signals2::detail::signal0_impl<void,class boost::signals2::optional_last_value<void>,int,struct std::less<int>,class boost::function<void __cdecl(void)>,class boost::function<void __cdecl(class boost::signals2::connection const &)>,class boost::signals2::mutex>::slot_invoker,class std::_List_iterator<class std::_List_val<class boost::shared_ptr<class boost::signals2::detail::connection_body<struct std::pair<enum boost::signals2::detail::slot_meta_group,class boost::optional<int> >,class boost::signals2::slot0<void,class boost::function<void __cdecl(void)> >,class boost::signals2::mutex> >,class std::allocator<class boost::shared_ptr<class boost::signals2::detail::connection_body<struct std::pair<enum boost::signals2::detail::slot_meta_group,class boost::optional<int> >,class boost::signals2::slot0<void,class boost::function<void __cdecl(void)> >,class boost::signals2::mutex> > > > >,clcc3763b0(optional_last_value<void>* , slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > first, slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > last)
   at boost.signals2.detail.signal0_impl<void,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(void)>,boost::function<void __cdecl(boost::signals2::connection const &)>,boost::signals2::mutex>.()(signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>* )
   at MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Forward Engineer without the server running.
[2 Sep 2012 1:53] Miguel Solorzano
Thank you for the bug report.

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
   at boost.function0<void>.()(function0<void>* )
   at boost.signals2.detail.slot_call_iterator_t<boost::signals2::detail::signal0_impl<void,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(void)>,boost::function<void __cdecl(boost::signals2::connection const &)>,boost::signals2::mutex>::slot_invoker,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> >,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> > > > >,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot0<void,boost::function<void __cdecl(void)> >,boost::signals2::mutex> 968d42b1(slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >* )
   at boost.signals2.optional_last_value<void>.operator()<class boost::signals2::detail::slot_call_iterator_t<class boost::signals2::detail::signal0_impl<void,class boost::signals2::optional_last_value<void>,int,struct std::less<int>,class boost::function<void __cdecl(void)>,class boost::function<void __cdecl(class boost::signals2::connection const &)>,class boost::signals2::mutex>::slot_invoker,class std::_List_iterator<class std::_List_val<class boost::shared_ptr<class boost::signals2::detail::connection_body<struct std::pair<enum boost::signals2::detail::slot_meta_group,class boost::optional<int> >,class boost::signals2::slot0<void,class boost::function<void __cdecl(void)> >,class boost::signals2::mutex> >,class std::allocator<class boost::shared_ptr<class boost::signals2::detail::connection_body<struct std::pair<enum boost::signals2::detail::slot_meta_group,class boost::optional<int> >,class boost::signals2::slot0<void,class boost::function<void __cdecl(void)> >,class boost::signals2::mutex> > > > >,clcc3763b0(optional_last_value<void>* , slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > first, slot_call_iterator_t<boost::signals2::detail::signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>::slot_invoker\,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> >\,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > > > >\,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group\,boost::optional<int> >\,boost::signals2::slot0<void\,boost::function<void __cdecl(void)> >\,boost::signals2::mutex> > last)
   at boost.signals2.detail.signal0_impl<void,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(void)>,boost::function<void __cdecl(boost::signals2::connection const &)>,boost::signals2::mutex>.()(signal0_impl<void\,boost::signals2::optional_last_value<void>\,int\,std::less<int>\,boost::function<void __cdecl(void)>\,boost::function<void __cdecl(boost::signals2::connection const \&)>\,boost::signals2::mutex>* )
   at MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[3 Sep 2012 13:28] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=66655 marked as duplicate of this one.
[13 Sep 2012 22:18] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=66809 marked as duplicate of this one.
[21 Sep 2012 16:31] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=66899 marked as duplicate of this one.
[27 Sep 2012 2:39] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=66977 marked as duplicate of this one.
[1 Oct 2012 18:25] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67039 marked as duplicate of this one.
[2 Oct 2012 12:42] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67047 marked as duplicate of this one.
[2 Oct 2012 13:47] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67055 marked as duplicate of this one.
[6 Oct 2012 13:36] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67107 marked as duplicate of this one.
[11 Oct 2012 17:52] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67187 duplicate of this one.
[15 Oct 2012 12:43] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67227 duplicate of this one.
[16 Oct 2012 9:33] Paulo Martins
Hi!

Is there any prediction on when this problem will be solved?

Thank you.

Best Regards.

Paulo J. F. Martins
[16 Oct 2012 11:28] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=67254 duplicate of this one.
[4 Nov 2012 3:24] Alfredo Kojima
duplicate of Bug #66646
[30 Nov 2012 2:27] Philip Olson
Fixed as of the upcoming MySQL Workbench 5.2.45, and here's the changelog entry:

An exception would be generated when executing "Forward Engineer" without
a MySQL Server connection.

Thank you for the bug report.