Bug #66620 Workbench stopped working while deleting column
Submitted: 30 Aug 2012 17:35 Modified: 15 Sep 2012 19:56
Reporter: Vassili Syskine Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.42 OS:Windows (Win7-64)
Assigned to: CPU Architecture:Any

[30 Aug 2012 17:35] Vassili Syskine
Workbench stopped working when I selected "delete" from the pop-up menu in the "columns" area.

How to repeat:
Opened model, copied one table, renamed copy, renamed one column in the new table, deleted two, renamed another one, attempted to delete yet one more column, then it crashed. While copying table I tried to do it via Ctrl-C/Ctrl-V, then via right click, neither worked, so I had to go to Edit menu to copy and paste, not sure if this has something to do with the crash.
[30 Aug 2012 17:48] MySQL Verification Team
I couldn't repeat. Do you have a project file model and step by step instructions so the issue is repeatable?. Thanks.
[30 Aug 2012 17:57] Vassili Syskine
It does not happen all the time. After the crash, I restarted Workbench and succeeded in copying-renaming-deleting columns. I am afraid I can not share my model as it contains proprietary information.
[13 Sep 2012 15:14] MySQL Verification Team
Please try version 5.2.43 . Thanks.
[14 Sep 2012 17:11] Vassili Syskine
Thank you! 5.2.43 did not crash after a quick test.
[15 Sep 2012 19:56] MySQL Verification Team
Thank you for the feedback.