Bug #66591 execution of all script doesn't work using lightning icon
Submitted: 29 Aug 2012 12:33 Modified: 24 Sep 2012 10:06
Reporter: Yurii Korotia Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.42 CE OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[29 Aug 2012 12:33] Yurii Korotia
Description:
execution of all script doesn't work

How to repeat:
1. put some code in one file like

drop procedure if exists sp1;
delimiter $$
create procedure sp1()
begin
select 1;
end$$

2. try to run whole script using lightning icon

3. you will get warning procedure doesn't exist

4. procedure won't be created

Suggested fix:
rollback to previous version 5.2.40
[29 Aug 2012 13:16] Valeriy Kravchuk
Where exactly cursor was positioned when you had this problem? See Bug #66505. 

For me on Windows XP entire script is executed.
[13 Sep 2012 9:38] Yurii Korotia
my bad for delay

yes. it looks like this

I had code similar to this

drop procedure sp1;
delimiter $$

/*
comment bla bla ;
*/
create procedure

So it duplicate of bug. As most of my files contain ';' in comments I stay with older version.

regards
[13 Sep 2012 17:26] Miguel Solorzano
Please try version 5.2.43. Thanks.
[24 Sep 2012 10:06] Yurii Korotia
going for 5.2.43